Устанавливаем V2ray сервер в Debian

Для чайников и не только
Аватара пользователя
Zyxmon
Администратор
Сообщения: 1904
Зарегистрирован: 09 авг 2015, 15:33

Сообщение Zyxmon » 05 янв 2023, 22:54

Такие заметки я пишу для себя, чтобы в следующий раз по своей инструкции быстро повторить.
Проекты shadowsocks и v2ray - китайские и инструкций по v2ray на английском или русском немного.
Первоисточник - https://www.v2ray.com/ru/ устарел. По инструкции с него не поставить. Но при выполнении установки, куда проект переехал будет написано как и что делать. Если что - поможет online переводчик с китайского.

1. Установка https://github.com/v2fly/fhs-install-v2ray

Код: Выделить всё

bash <(curl -L https://raw.githubusercontent.com/v2fly/fhs-install-v2ray/master/install-release.sh)

2. Генерим ID командой

Код: Выделить всё

cat '/proc/sys/kernel/random/uuid'

3. Создаем правильный конфиг сервера /usr/local/etc/v2ray/config.json с этим ID как описано в Project V и конфиг для клиента. Клиент под Windows, который использовал Qv2ray.


PS Для debian можно все сделать проще - `apt-get install v2ray`. Но версия v2ray будет не последняя.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1904
Зарегистрирован: 09 авг 2015, 15:33

Сообщение Zyxmon » 06 янв 2023, 13:36

В продолжение темы. Стам гуглить, как установить Trojan сервер. Нашел это - https://www.oilandfish.com/posts/quickl ... an-go.html

За полтора года с момента этой статьи китайцы скрипт обновили, статье не до конца соответсвует. Частично перевели на английский описание и сам скрипт - https://github.com/jinwyp/one_click_scr ... README2.md
При запуске есть выбор языка - китайский или английский. Главное меню (обрезано) на английском:
trojan.jpg
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1904
Зарегистрирован: 09 авг 2015, 15:33

Сообщение Zyxmon » 18 янв 2023, 20:04

Проверил скрипт из последнего поста. Работает. Задает уточняюще вопросы на китайском (держите под боком online переводчик)

Код: Выделить всё

==================================================
 请选择安装 Trojan 或 Trojan-go ? 默认选择4 修改版Trojan-go

 1 原版 Trojan 不支持 websocket (not support websocket)
 2 原版 Trojan-go 支持 websocket (support websocket)
 3 修改版 Trojan-go 支持 websocket by fregie (support websocket)
 4 修改版 Trojan-go 支持模拟浏览器指纹 支持 websocket by Potterli20 (support websocket)

请选择哪种 Trojan ? 直接回车默认选4, 请输入纯数字:4

Не все прошло идеально. Задание cron для обновления сертификатов LetsEncrypt не было создано. Но это дело поправимое. Проверял под Ubuntu 22.04.1 LTS.


Вернуться в «Linux - все вопросы тут»

Кто сейчас на конференции

Всего 1 посетитель :: 1 зарегистрированный, 0 скрытых и 0 гостей (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (162) здесь было 16 ноя 2019, 18:33

Сейчас этот форум просматривают: CommonCrawl [Bot] и 0 гостей