python apkutils

Используем пакеты, расширяющие возможности оборудования
Pasha_ZZZ
Сообщения: 51
Зарегистрирован: 31 окт 2015, 11:29

Сообщение Pasha_ZZZ » 23 апр 2022, 08:41

Здравствуйте. Раньше (когда-то) ставил модуль apkutils для python3 и все работало. Теперь затыкается на зависимостях, вроде бы просит cryptography 35.0.0+ (а в Entware есть только 3.4.8, странные номера версий какие-то)...

Аватара пользователя
TheBB
Сообщения: 112
Зарегистрирован: 31 авг 2015, 02:24
Откуда: 26 ~44.098,43.022

Сообщение TheBB » 28 апр 2022, 13:28

Pasha_ZZZ писал(а):Источник цитаты а в Entware есть только 3.4.8
Она (версия) и в OpenWrt такая же.
Pasha_ZZZ писал(а):Источник цитаты вроде бы просит cryptography 35.0.0+
Если mipsel, можете попробовать

Код: Выделить всё

opkg install http://bin.entware.net/mipselsf-k3.4/test/HA/python3-cryptography_36.0.0-1_mipsel-3.4.ipk
K Giga II NDMSv.2.06C/2.11D/2.15A + Entware-Keenetic/Entware&Gentoo; K DSL NDMSv.2.05C/2.11D + Entware-Keenetic/Entware&Debian 8.11/9.6

Pasha_ZZZ
Сообщения: 51
Зарегистрирован: 31 окт 2015, 11:29

Сообщение Pasha_ZZZ » 01 май 2022, 08:37

TheBB писал(а):Источник цитатыЕсли mipsel, можете попробовать

К сожалению
armv7sf-k3.2

Аватара пользователя
TheBB
Сообщения: 112
Зарегистрирован: 31 авг 2015, 02:24
Откуда: 26 ~44.098,43.022

Сообщение TheBB » 01 май 2022, 18:23

Pasha_ZZZ писал(а):Источник цитаты К сожалению
Печалька, да и не суть важно, я там глянул ('cryptography>=35.0.0,<36.0.0'), не взлетит, надо собирать "cryptography" 35-й версии или ставить пакет "apkutils" до 0.10.2 версии включительно (с версии 0.11.0 уже требует "cryptography = "^35.0.0"").
K Giga II NDMSv.2.06C/2.11D/2.15A + Entware-Keenetic/Entware&Gentoo; K DSL NDMSv.2.05C/2.11D + Entware-Keenetic/Entware&Debian 8.11/9.6

Аватара пользователя
TheBB
Сообщения: 112
Зарегистрирован: 31 авг 2015, 02:24
Откуда: 26 ~44.098,43.022

Сообщение TheBB » 01 май 2022, 20:44

Pasha_ZZZ писал(а):Источник цитаты armv7sf-k3.2
as is
"Не взлетим, так попрыгаем..."
K Giga II NDMSv.2.06C/2.11D/2.15A + Entware-Keenetic/Entware&Gentoo; K DSL NDMSv.2.05C/2.11D + Entware-Keenetic/Entware&Debian 8.11/9.6

Pasha_ZZZ
Сообщения: 51
Зарегистрирован: 31 окт 2015, 11:29

Сообщение Pasha_ZZZ » 02 май 2022, 05:29

TheBB писал(а):Источник цитаты "Не взлетим, так попрыгаем..."
Да, теперь крипта взлетела. Стало ругаться на lief (его тоже пытается собрать из исходников и не находит CMake).

Аватара пользователя
TheBB
Сообщения: 112
Зарегистрирован: 31 авг 2015, 02:24
Откуда: 26 ~44.098,43.022

Сообщение TheBB » 04 май 2022, 19:51

Pasha_ZZZ писал(а):Источник цитатыСтало ругаться на lief (его тоже пытается собрать из исходников и не находит CMake).
Пакет "cmake" в репах есть, но... lief собирается о-о-о-очень до-о-о-олго-о-о (на ZKeenetic Ultra2 ~ сутки)...
K Giga II NDMSv.2.06C/2.11D/2.15A + Entware-Keenetic/Entware&Gentoo; K DSL NDMSv.2.05C/2.11D + Entware-Keenetic/Entware&Debian 8.11/9.6

Pasha_ZZZ
Сообщения: 51
Зарегистрирован: 31 окт 2015, 11:29

Сообщение Pasha_ZZZ » 05 май 2022, 08:20

TheBB писал(а):Источник цитаты Пакет "cmake" в репах есть, но... lief собирается о-о-о-очень до-о-о-олго-о-о

Поэтому и не ставлю, да и вдруг памяти не хватит например, при сборке...

Аватара пользователя
TheBB
Сообщения: 112
Зарегистрирован: 31 авг 2015, 02:24
Откуда: 26 ~44.098,43.022

Сообщение TheBB » 05 май 2022, 16:46

Сильно ковыряться было не охота... Объём небольшой, потому тут (без pastebin)
Makefile

Код: Выделить всё

# SPDX-License-Identifier: WTFPL

include $(TOPDIR)/rules.mk

PKG_NAME:=python3-lief
PKG_VERSION:=0.11.5
PKG_RELEASE:=1

PYPI_NAME:=lief
PYPI_SOURCE_EXT:=zip
PKG_HASH:=932ba495388fb52b4ba056a0b00abe0bda3567ad3ebc6d726be1e87b8be08b3f

PKG_LICENSE:=Apache-2.0
PKG_LICENSE_FILES:=LICENSE

include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
include $(INCLUDE_DIR)/package.mk
include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk

define Package/python3-lief
  SECTION:=lang
  CATEGORY:=Languages
  SUBMENU:=Python
  TITLE:=Library to instrument executable formats
  URL:=https://github.com/lief-project/LIEF
  DEPENDS:=+libstdcpp +python3-base
endef

define Package/python3-lief/description
  The purpose of this project is to provide a cross platform library which
  can parse, modify and abstract ELF, PE and MachO formats. 
endef

PYTHON3_PKG_SETUP_GLOBAL_ARGS += --ninja

define Package/python3-lief/install
	$(INSTALL_DIR) $(1)/opt/bin
	$(CP) $(PKG_INSTALL_DIR)/opt/bin/* $(1)/opt/bin
	$(call Python3/FixShebang,$(1)/opt/bin/*)

	$(INSTALL_DIR) $(1)$(PYTHON3_PKG_DIR)
	$(CP) $(PKG_INSTALL_DIR)$(PYTHON3_PKG_DIR)/* $(1)$(PYTHON3_PKG_DIR)
endef

$(eval $(call Py3Package,python3-lief))
$(eval $(call BuildPackage,python3-lief))
#$(eval $(call BuildPackage,python3-lief-src))

Свернуть
010-fix-cross.patch

Код: Выделить всё

--- a/cmake/FindPythonLibsNew.cmake
+++ b/cmake/FindPythonLibsNew.cmake
@@ -118,7 +118,8 @@ list(GET _PYTHON_VALUES 9 PYTHON_MULTIAR
 
 # Make sure the Python has the same pointer-size as the chosen compiler
 # Skip if CMAKE_SIZEOF_VOID_P is not defined
-if(CMAKE_SIZEOF_VOID_P AND (NOT "${PYTHON_SIZEOF_VOID_P}" STREQUAL "${CMAKE_SIZEOF_VOID_P}"))
+if(NOT DEFINED CMAKE_CROSSCOMPILING)
+  if(CMAKE_SIZEOF_VOID_P AND (NOT "${PYTHON_SIZEOF_VOID_P}" STREQUAL "${CMAKE_SIZEOF_VOID_P}"))
     if(PythonLibsNew_FIND_REQUIRED)
         math(EXPR _PYTHON_BITS "${PYTHON_SIZEOF_VOID_P} * 8")
         math(EXPR _CMAKE_BITS "${CMAKE_SIZEOF_VOID_P} * 8")
@@ -128,6 +129,7 @@ if(CMAKE_SIZEOF_VOID_P AND (NOT "${PYTHO
     endif()
     set(PYTHONLIBS_FOUND FALSE)
     return()
+  endif()
 endif()
 
 # The built-in FindPython didn't always give the version numbers

Свернуть
Собсна, уже собранный пакет
K Giga II NDMSv.2.06C/2.11D/2.15A + Entware-Keenetic/Entware&Gentoo; K DSL NDMSv.2.05C/2.11D + Entware-Keenetic/Entware&Debian 8.11/9.6

Pasha_ZZZ
Сообщения: 51
Зарегистрирован: 31 окт 2015, 11:29

Сообщение Pasha_ZZZ » 08 май 2022, 14:51

Запустился, ура! Только видимо в версии 1.х все сильно переделали, надо свой код тоже перетряхивать...


Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 4 посетителя :: 2 зарегистрированных, 0 скрытых и 2 гостя (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (162) здесь было 16 ноя 2019, 18:33

Сейчас этот форум просматривают: Bing [Bot], CommonCrawl [Bot] и 2 гостя