Соберите, пожалуйста, пакет ...

Используем пакеты, расширяющие возможности оборудования
Аватара пользователя
Zyxmon
Администратор
Сообщения: 1797
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 23 авг 2015, 07:06

В этой теме оставляйте Ваши заявки.
Приблизительный шаблон:
---------------------------------------
Соберите, пожалуйста, пакет XXX, версия YYY.
Ссылка на исходники - http:://
Пакет (есть, нет, не знаю) в Openwrt.

Я использую железку ZZZ с Entware.mipsel фид mipselsf
Готов протестировать
-------------------------------------

Аватара пользователя
TheBB
Сообщения: 95
Зарегистрирован: 31 авг 2015, 01:24
Откуда: 26 ~44.098,43.022

Сообщение TheBB » 03 мар 2020, 20:58

Код: Выделить всё

opkg install http://bin.entware.net/mipselsf-k3.4/test/crelay_0.13-1_mipsel-3.4.ipk

тестим-отписываемся
K Giga II NDMSv.2.06C/2.11D/2.15A + Entware-Keenetic/Entware&Gentoo; K DSL NDMSv.2.05C/2.11D + Entware-Keenetic/Entware&Debian 8.11/9.6

isvlad
Сообщения: 7
Зарегистрирован: 04 янв 2016, 21:32

Сообщение isvlad » 07 мар 2020, 18:14

TheBB писал(а):Источник цитаты тестим-отписываемся


Переустановил Entware? Поставил crelay. Заработало ! :) Большое спасибо!!! Единственно момент. Собирали из https://github.com/ondrej1024/crelay ? Дело в том, что 13 версия глючная слегка. У автора вроде как 14 выложена.

SerZ
Сообщения: 1
Зарегистрирован: 16 мар 2020, 20:19

Сообщение SerZ » 16 мар 2020, 21:05

Собрал для себя node.js посвежее, может ещё кому пригодится.

Собирал не из основной ветки OpenWrt, "по мотивам" nxhack/openwrt-node-packages - адаптировал эту репу под Entware, сделал свой Makefile (добавил 14-ой версии, убрал поддержку 10й версии).

Для работы обеих версий нужна libuv посвежее, cначала ставим пакет libuv, потом ноду.

Каталог с последними версиями: node
Последний раз редактировалось SerZ 18 май 2020, 07:58, всего редактировалось 5 раз.
Padavan@KN-ULTRA2

playtester
Сообщения: 5
Зарегистрирован: 24 дек 2018, 14:43

Сообщение playtester » 31 мар 2020, 10:59

Соберите пожалуйста пакеты, готов потестировать. Устройства Keenetic II, Keenetic Onmi II, Keenetic Omni (KN-1410)
https://openwrt.org/packages/pkgdata_lede17_1/reaver
https://openwrt.org/packages/pkgdata_owrt18_6/pixiewps

Аватара пользователя
Александр Рыжов
Сообщения: 418
Зарегистрирован: 12 авг 2015, 13:14
Откуда: Смоленск

Сообщение Александр Рыжов » 31 мар 2020, 11:39

playtester, зачем запускать утилиты для брутфорса на столь убогом MIPS-процессоре?
pixiewps, кстати, есть в репозитории, можете оценить скорость его работы.

playtester
Сообщения: 5
Зарегистрирован: 24 дек 2018, 14:43

Сообщение playtester » 31 мар 2020, 14:09

Александр Рыжов писал(а):Источник цитаты playtester, зачем запускать утилиты для брутфорса на столь убогом MIPS-процессоре?
pixiewps, кстати, есть в репозитории, можете оценить скорость его работы.

На дешёвых тп линках с openwrt, вполне нормально работает (например wr842n). Даже и не знал, что pixiewps уже есть в репозитории, в списке пакетов mipsel он не указан.

Аватара пользователя
Александр Рыжов
Сообщения: 418
Зарегистрирован: 12 авг 2015, 13:14
Откуда: Смоленск

Сообщение Александр Рыжов » 31 мар 2020, 20:38

Список пакетов для вашей архитектуры здесь.

tim-tam
Сообщения: 2
Зарегистрирован: 05 апр 2020, 16:59

Сообщение tim-tam » 05 апр 2020, 17:06

Соберите пожалуйста пакет shntool, версия 3.0.10
Исходники здесь: http://shnutils.freeshell.org/shntool/
В репозитории пакета нет.

Я использую NAS QNAP TS-119 (на arm проце)
Готов протестировать.

Аватара пользователя
Александр Рыжов
Сообщения: 418
Зарегистрирован: 12 авг 2015, 13:14
Откуда: Смоленск

Сообщение Александр Рыжов » 05 апр 2020, 20:23

Где проверяли наличие пакета? В актуальном репозитории он есть.

tim-tam
Сообщения: 2
Зарегистрирован: 05 апр 2020, 16:59

Сообщение tim-tam » 07 апр 2020, 21:42

Я просто пытался установить этот пакет, но получил такое сообщение:
Unknown package 'shntool'.
Collected errors:
* opkg_install_cmd: Cannot install package shntool.

Возможно, я использую устаревший установщик пакетов - я установил Qnapware 0.82 (для установки mc на NAS этого было достаточно)
Что я могу установить из более современного чтобы использовать полный репозиторий?

Все. Разобрался.
Установил по этой https://github.com/Entware/Entware/wiki ... n-QNAP-NAS инструкции entware.
После этого установил shntool


Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 3 посетителя :: 1 зарегистрированный, 0 скрытых и 2 гостя (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (162) здесь было 16 ноя 2019, 17:33

Сейчас этот форум просматривают: CommonCrawl [Bot] и 2 гостя