проблема с устновкой Entware-3x на LEDE 17.01.2 ZBT-WG3526

Используем пакеты, расширяющие возможности оборудования
alexzbt
Сообщения: 6
Зарегистрирован: 17 авг 2017, 15:51

Сообщение alexzbt » 17 авг 2017, 16:01

Привет!

Код: Выделить всё

root@LEDE:~# uname -a
Linux LEDE 4.4.71 #0 SMP Thu Jun 8 17:57:31 2017 mips GNU/Linux
root@LEDE:~# mount
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,noatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mtdblock6 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)
tmpfs on /dev type tmpfs (rw,nosuid,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,mode=600)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
/dev/sda1 on /opt type ext4 (rw,relatime,data=ordered)
root@LEDE:~# wget -O - http://entware-3x.zyxmon.org/binaries/mips/installer/install_std.sh | sh
Downloading 'http://entware-3x.zyxmon.org/binaries/mips/installer/install_std.sh'
Connecting to 81.4.123.217:80
Writing to stdout
-                    100% |*******************************|  2283 Info: Checking for prerequisites and creating folders...
  0:00:00 ETA
Download completed (2283 bytes)
Warning: Folder /opt exists!
Info: Opkg package manager deployment...
Downloading 'http://entware-3x.zyxmon.org/binaries/mips/installer/2017/opkg'
Connecting to 81.4.123.217:80
Writing to '/opt/bin/opkg'
/opt/bin/opkg        100% |*******************************|   135k  0:00:00 ETA
Download completed (138836 bytes)
Downloading 'http://entware-3x.zyxmon.org/binaries/mips/installer/2017/opkg.conf'
Connecting to 81.4.123.217:80
Writing to '/opt/etc/opkg.conf'
/opt/etc/opkg.conf   100% |*******************************|   147   0:00:00 ETA
Download completed (147 bytes)
Downloading 'http://entware-3x.zyxmon.org/binaries/mips/installer/2017/ld-2.25.so'
Connecting to 81.4.123.217:80
Writing to '/opt/lib/ld-2.25.so'
/opt/lib/ld-2.25.so  100% |*******************************|   146k  0:00:00 ETA
Download completed (150220 bytes)
Downloading 'http://entware-3x.zyxmon.org/binaries/mips/installer/2017/libc-2.25.so'
Connecting to 81.4.123.217:80
Writing to '/opt/lib/libc-2.25.so'
/opt/lib/libc-2.25.s 100% |*******************************|  1578k  0:00:00 ETA
Download completed (1616316 bytes)
Downloading 'http://entware-3x.zyxmon.org/binaries/mips/installer/2017/libgcc_s.so.1'
Connecting to 81.4.123.217:80
Writing to '/opt/lib/libgcc_s.so.1'
/opt/lib/libgcc_s.so 100% |*******************************| 93848   0:00:00 ETA
Download completed (93848 bytes)
Downloading 'http://entware-3x.zyxmon.org/binaries/mips/installer/2017/libpthread-2.25.so'
Connecting to 81.4.123.217:80
Writing to '/opt/lib/libpthread-2.25.so'
/opt/lib/libpthread- 100% |*******************************|   119k  0:00:00 ETA
Download completed (122696 bytes)
Info: Basic packages installation...
/opt/bin/opkg: line 11: syntax error: unexpected "("
/opt/bin/opkg: line 11: syntax error: unexpected "("
/opt/bin/opkg: line 11: syntax error: unexpected "("
Info: Congratulations!
Info: If there are no errors above then Entware-3x was successfully initialized.
Info: Add /opt/bin & /opt/sbin to your PATH variable
Info: Add '/opt/etc/init.d/rc.unslung start' to startup script for Entware-3x services to start
Info: Found a Bug? Please report at https://github.com/Entware-for-kernel-3x/Entware-ng-3x/issues

после этого нет /opt/etc/profile и в PATH= нет /opt/bin

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1331
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 17 авг 2017, 17:32

Это не mips. Это mipsel!

alexzbt
Сообщения: 6
Зарегистрирован: 17 авг 2017, 15:51

Сообщение alexzbt » 18 авг 2017, 23:08

Zyxmon, спасибо, с mipsel все ок. На это стоит обращать внимание:

Код: Выделить всё

root@LEDE:~# epkg update
Package dvb-center version 0.1-1 has no valid architecture, ignoring.
Package ext-ui-lighttpd-7 version 0.2-2a has no valid architecture, ignoring.
Package ext-ui-nginx-7 version 0.2-2 has no valid architecture, ignoring.
Package libndm version 1.1.0-1a has no valid architecture, ignoring.
Package music-center version 0.1-2c has no valid architecture, ignoring.
Package ndmq version 1.0.2-1a has no valid architecture, ignoring.
Package opt-ndmsv2 version 1.0-8a has no valid architecture, ignoring.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1331
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 18 авг 2017, 23:23

Это нормально. Часть пакетов в репе для других железок.


Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 2 посетителя :: 0 зарегистрированных, 0 скрытых и 2 гостя (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя