WEB камера в Entware-Keenetic

Используем пакеты, расширяющие возможности оборудования
teuton
Сообщения: 8
Зарегистрирован: 10 сен 2016, 18:13

Сообщение teuton » 10 сен 2016, 18:47

Здравствуйте! В наличии имеется Giga2 с прошивкой v2.06(AAFS.2)C0. Web камера определяется, но во время установки в логах пишет о неудаче. После установки пакета mjpg-streamer-zyx процессор грузит на 100%.

 
[I] Sep 8 23:00:17 ndm: kernel: usb 1-1: USB disconnect, address 6
[I] Sep 8 23:00:23 ndm: kernel: usb 1-1: new high speed USB device using rt3xxx-ehci and address 7
[I] Sep 8 23:00:23 ndm: kernel: usb 1-1: configuration #1 chosen from 1 choice
[I] Sep 8 23:00:23 ndm: kernel: uvcvideo: Found UVC 1.00 device A4TECH USB2.0 PC Camera (0ac8:3420)


[I] Sep 9 00:58:03 ndm: Opkg::Manager: /opt/etc/init.d/S96mjpg-streamer: starting mjpg_streamer...
[I] Sep 9 00:58:03 MJPG-streamer [1191]: starting application
[I] Sep 9 00:58:03 MJPG-streamer [1191]: enabling daemon mode
[I] Sep 9 00:58:03 MJPG-streamer [1193]: MJPG Streamer Version: svn rev: Unversioned directory
[I] Sep 9 00:58:03 MJPG-streamer [1193]: Using V4L2 device.: /dev/video0
[I] Sep 9 00:58:03 MJPG-streamer [1193]: Desired Resolution: 320 x 240
[I] Sep 9 00:58:03 MJPG-streamer [1193]: Frames Per Second.: 5
[I] Sep 9 00:58:03 MJPG-streamer [1193]: Format............: MJPEG
[I] Sep 9 00:58:03 ndm: Opkg::Manager: /opt/etc/init.d/S96mjpg-streamer: enabling daemon modeforked to background (1193).
[I] Sep 9 00:58:03 MJPG-streamer [1193]: init_VideoIn failed
[I] Sep 9 00:58:08 ndm: Core::ConfigurationSaver: configuration saved.
[E] Sep 9 00:58:51 ndm: Opkg::Manager: /opt/etc/init.d/S96mjpg-streamer: timed out.
Свернуть


Подскажите кто знает, как решить проблему. Может я что-нибудь не так делаю, может что-то ещё дополнительно к пакету надо ставить. Если не затруднит, то пошагово опишите пожалуйста.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1333
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 11 сен 2016, 07:11

Проверьте работу камеры с прошивкой v1. Там поддержка из коробки. Если и там не работает - проблема с совместимостью.

teuton
Сообщения: 8
Зарегистрирован: 10 сен 2016, 18:13

Сообщение teuton » 11 сен 2016, 09:25

Работала на V1, хорошо помню. А подскажите модель webки, заведомо рабочую на V2, Проверю сей момент.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1333
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 11 сен 2016, 11:25

Переходите на v1.

teuton
Сообщения: 8
Зарегистрирован: 10 сен 2016, 18:13

Сообщение teuton » 11 сен 2016, 12:20

Причиной перехода на V2 послужила невозможность настройки IPTV от Ростелекома. В то время их Sagemcom работал в режиме моста, но он просто бесил меня своей ....работой, да + розетку занимал :) . Кстати вы говорите проблема с совместимостью, а как же тогда, что после установки пакета mjpg-streamer-zyx процессор грузит на 100% и это при НЕ подключённой камере?

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1333
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 12 сен 2016, 07:20

С v1 работает, значит совместима.

Аватара пользователя
TheBB
Сообщения: 78
Зарегистрирован: 31 авг 2015, 01:24
Откуда: 26 ~44.09,43.02

Сообщение TheBB » 12 сен 2016, 13:14

teuton, выложите на http://pastebin.com/ весь лог (из присланной вырезки не очень понятно...) и вывод `opkg list-installed` , ссылки - сюда
Keenetic Giga II NDMSv.2.06/2.11 + Entware-Keenetic/Entware-ng-3x&Gentoo; Keenetic DSL NDMSv.2.05/2.11 + Entware-Keenetic/Entware-ng-3x&Debian

teuton
Сообщения: 8
Зарегистрирован: 10 сен 2016, 18:13

Сообщение teuton » 12 сен 2016, 23:15

Вот, прошу смотреть.
http://pastebin.com/xWwtNiw9 и http://pastebin.com/XfY13aTZ

Аватара пользователя
TheBB
Сообщения: 78
Зарегистрирован: 31 авг 2015, 01:24
Откуда: 26 ~44.09,43.02

Сообщение TheBB » 13 сен 2016, 03:35

по пакетам - если это все - то нормально (сразу скажу, что с "музыкальной шкатулкой" - не совсем совместим).
лог - это тот, что берется из "система" - "файлы" - "log" "сохранить" (ну, да ладно...).
камера подключена. диск с меткой "disk_A1" смонтирован. ставите систему (установка проходит без ошибок). подключаетесь к устройству. что-то ковыряете минут 10 и... ...и в 3:37 начинаете пляски с бубном ;)
1 если отключаете диск на вкладке "OPKG" - там же прописывайте строку инициализации /opt/etc/init.d/rc.unslung !!!обратно вручную!!!
2 кладет в 100% CPU бинарник `yes` в скрипте запуска S96mjpg-streamer (строка 15). попробуйте сделать, как на картинке
streamer.jpeg
Свернуть
У вас нет необходимых прав для просмотра вложений в этом сообщении.
Keenetic Giga II NDMSv.2.06/2.11 + Entware-Keenetic/Entware-ng-3x&Gentoo; Keenetic DSL NDMSv.2.05/2.11 + Entware-Keenetic/Entware-ng-3x&Debian

teuton
Сообщения: 8
Зарегистрирован: 10 сен 2016, 18:13

Сообщение teuton » 13 сен 2016, 07:49

по 1. заметил что, при прописывании строки инициализации /opt/etc/init.d/rc.unslung в логе отсутствует строка Opkg::Manager: /opt/etc/init.d/S96mjpg-streamer: starting mjpg_streamer... и подобное (S96mjpg).
по 2. а что это на картинке? :oops: я не очень то разбираюсь в этом. Вроде не SSH и не telnet, как это запустить?


Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 5 посетителей :: 0 зарегистрированных, 0 скрытых и 5 гостей (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 5 гостей