Entware-3x - новые репозитории Entware для устройств, использующих новые ядра.

Используем пакеты, расширяющие возможности оборудования
Xaber
Сообщения: 3
Зарегистрирован: 22 дек 2016, 16:37

Сообщение Xaber » 22 дек 2016, 16:52

На NG было:
# ldconfig -v | grep libc.so
libc.so.0 => libuClibc-1.0.16.so
ld-uClibc.so.1 => ld-uClibc-1.0.16.so

На 3X стало:
# ldconfig -v | grep libc.so
ldconfig: Path `/lib' given more than once
ldconfig: Can't stat /lib32: No such file or directory
ldconfig: Can't stat /lib64: No such file or directory
libc.so.0 -> libuClibc-0.9.33.2.so
ld-uClibc.so.0 -> ld-uClibc-0.9.33.2.so


Аватара пользователя
Zyxmon
Администратор
Сообщения: 1232
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 22 дек 2016, 17:02

Xaber писал(а):Источник цитаты Вроде получилось, но при каждом запуске OPKG вот такое:

Это нормально. Несколько пакетов собрано для другой платформы. Отдельную репу делать для них не стали.
Xaber писал(а):Источник цитаты Ну и смущает меня ldconfig

Не пользуюсь, не смотрел. Считаю, что ничего страшного. ldd и ldconfig собираются вместе с системной либой. Она поменялась uclibc-ng->glibc. ldd доработан напильником (это теперь скрипт, использующий dynamic-loader).

Xaber
Сообщения: 3
Зарегистрирован: 22 дек 2016, 16:37

Сообщение Xaber » 22 дек 2016, 20:03

Скажите пожалуйста, как в таком случае я могу увидеть версию Glibc? У меня не работает бинарник собраный для MIPS и Glibc, я думал, что дело в Uclibc, а теперь вообще запутался.
И еще нашёл на форуме вы упоминали chrpath для Entware. Я теперь подозреваю что мой бинарник ищет библиотеки не там где надо. И насколько понимаю нужен chrpath для того чтобы указать ему в /opt/lib/ но в менеджере пакетов chrpath нету.
file ps3netsrv_mips_aldostools
ps3netsrv_mips_aldostools: ELF 32-bit LSB executable, MIPS, MIPS-I version 1 (SYSV), dynamically linked, interpreter /lib/ld.so.1, for GNU/Linux 2.6.18,

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1232
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 22 дек 2016, 22:01

Xaber, Ваши вопросы к Entware-3x отношения не имеют. Чужие бинарники с помощью библиотек Entware запустить не получиться. От слова совсем.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1232
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 27 дек 2016, 13:41

Проведена синхронизация с openwrt, изменено более 150 пакетов, новые пакеты добавлены (знак +).
Сокращенный список измененных пакетов

Код: Выделить всё

3proxy_0.8.8
accel-ppp_1.11.1
aria2_1.28.0
avrdude_6.3
bacula_7.4.4
badblocks_1.43.3
baidupcs_0.2.5-20161120
bind*_9.10.4-P4
boost_1.62.0
busybox_1.25.1
ca-certificates_20161130
certtool_3.5.6
+ cgdisk_1.0.1
chattr_1.43.3
cups_2.2.1
cups-filters_1.13.0
curl_7.51.0
debugfs_1.43.3
dnscrypt-proxy-resolvers_1.7.0+git-20161129-f17bace
dtach_0.9
duktape_1.6.0
e2fsprogs_1.43.3
ethtool_4.8
exfat-fuse_1.2.5
+ f2fsck_1.7.0
+ f2fs-tools_1.7.0
fdupes_1.6.1-20161028
fuse-utils_2.9.7
gdb_7.11.1
+ gdisk_1.0.1
git_2.10.2
gnuchess_6.2.4
gnutls-utils_3.5.6
goaccess_1.1.1-20161206
gutenprint_5.2.12-pre4
hdparm_9.50
hplip_3.16.11
i2pd_2.10.2-20161207
imapfilter_2.6.9
inadyn_2.1
ipset_6.30
ldconfig_2.23
lft_3.77
lftp_4.7.4
libarchive_3.2.2
libassuan_2.4.3
libblobmsg-json_2016-11-29-77a629375d7387a33a59509d9d751a8798134cab
libconfig_1.5
libelf1_0.167
+ libf2fs_1.7.0
libgnutls_3.5.6
libgpg-error_1.25
libgpgme_1.8.0
libjson-script_2016-11-29-77a629375d7387a33a59509d9d751a8798134cab
- libloudmouth1_1.5.3-1 переименован в loudmouth_1.5.3
libmnl_1.0.4
libnetfilter-conntrack_1.0.6
libnettle_3.3
libnl*_3.2.28
libpcap_1.8.1
libpolarssl_1.3.18
libpoppler_0.49.0
libreadline_7.0
ruby_2.3.3-*
libslang2_2.3.1
libubox_2016-11-29-77a629375d7387a33a59509d9d751a8798134cab
libwebsockets-openssl_2.0.3
lighttpd_1.4.42
live555mediaserver_2016.11.28
live555proxyserver_2016.11.28
+ lm-sensors_3.3.5
+ lm-sensors-detect_3.3.5
+ loudmouth_1.5.3-1 (переименование)
lsattr_1.43.3
mako_1.0.6
mcabber_1.0.4
mediafire-fuse_0.9-20160112
mediainfo_0.7.91
mercurial_4.0
+ mkf2fs_1.7.0
mkvtoolnix_9.6.0
movgrab_2.1.0-20161119
+ msd_lite_1.08
mutt_1.7.2
nano_2.7.1
ncat_7.31
ncftp_3.2.6
ndiff_7.31
nethogs_0.8.5-20161120
net-tools*_2016-10-06
nfs-kernel-server_1.3.4
nmap_7.31
nping_7.31
ntfs-3g_2016.2.22-1-fuseext
ntpd_4.2.8p9
nyancat_1.5.1-20160824
ocserv_0.11.6
openrtsp_2016.11.28
+ opentracker_20151211
1142,1145c1129,1132
openvpn-*_2.3.13
oscam_1.20-r11289
pagekite_0.5.9.0
par2cmdline_0.6.14-20161105
pcap_dnsproxy_0.4.8.2
pcsc-tools_1.4.27-20161126
php5_5.6.29
php7_7.0.13
playsip_2016.11.28
poppler-utils_0.49.0
postfix_3.1.3
ps3netsrv_20160416
pyload_0.4.9-20161208
python3-requests_2.12.3
python-greenlet_0.4.11
python-psutil_5.0.0
python-regex_2016.11.21
python-requests_2.12.4
python-urllib3_1.19
quagga_1.1.0
redis_3.2.6
ruby_2.3.3
ser2net_3.2
+ sgdisk_1.0.1
shairport-sync*_2.8.6
shellinabox_2.20-20161109
simplejson_3.10.0
+ sipgrep_20160914-devel
slsh_2.3.1
sshfs_2.8
strace_4.14
strongswan_5.5.1
stunnel_5.38
subversion*_1.9.5
tcpdump_4.8.1
tor_0.2.8.9
+ ttyd_1.2.1
tune2fs_1.43.3
unionfs-fuse_2.0
uqmi_2016-11-22-d682e966615fc652da6e4e26b57aa3adfebeb2fe
urbackup-server_2.0.38
valgrind_3.12.0
vobstreamer_2016.11.28
vtun_3.0.4
whob_3.77
whois_5.2.13
youtube-dl_2016.11.27
zoneinfo-*_2016g

Voxel
Сообщения: 35
Зарегистрирован: 29 фев 2016, 12:34

Сообщение Voxel » 15 фев 2017, 18:38

Добрый вечер,

Предугадывая, что Вы будете проводить очередную синхронизацию с OpenWRT/LEDE ;-)

Пардон, если есть резоны, которых я не знаю, но все же: а не хотите все же попробовать чуть опередить эти, безусловно, отличные проекты? Я имею в виду связку openssl, openvpn-openssl и liblz4.

В OpenSSL я бы все же включил ASM акселерацию для ARM процессоров, которая почему-то выключена в OpenWRT и LEDE (всего убрать комментарии в закомментированных строчках в Makefile).

В OpenVPN 2.4.0 я бы использовал внешнюю библиотеку liblz4 вместо тех совместимых кодов, что уже в кодах OpenVPN (добавить зависимости от liblz4 в Makefile)

Ну и использовать liblz4 версии 1.7.5 вместо версии r131, так как они как вроде значительно ускорили ее на ARMv7 и ARMv6, начиная с 1.7.3:

Код: Выделить всё

Improved: Small decompression speed boost
Improved: Small compression ratio and speed improvement on small files
Improved: Significant speed boost on ARMv6 and ARMv7


Voxel.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1232
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 15 фев 2017, 21:01

Voxel писал(а):Источник цитаты если есть резоны, которых я не знаю

Резоны элементарные - сейчас уже 2000+ пакетов. Чем больше отличий от upsteam (openwrt), тем сложнее всем этим управлять. Поэтому без особой нужды стараемся как можно меньше отходить от openwrt. Лучше более универсальный пакет, чем более быстрый.

Voxel
Сообщения: 35
Зарегистрирован: 29 фев 2016, 12:34

Сообщение Voxel » 16 фев 2017, 09:44

Понятненько... Ну ладно, хотя и жаль.

Спасибо,

Voxel.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1232
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 21 фев 2017, 12:06

Проведена очередная сихронизация
(1) trunk синхронизирован с lede (поскольку lede и openwrt объединяются - http://lists.infradead.org/pipermail/le ... 04786.html )
(2) пакеты с openwrt

Изменений в системе сборки buildroot много, возможны проблемы.

Пакеты на языке GO теперь собираются с помощью GO от Google, компилятор gccgo не используется, т.к. начиная с версии 1.8 поддержаны mips/mipsel 32 разряда. Есть одно ограничение (важно для dd-wrt - на прошивках dd-wrt теперь работать не будет):
Go now supports 32-bit MIPS on Linux for both big-endian (linux/mips) and little-endian machines (linux/mipsle) that implement the MIPS32r1 instruction set with FPU or kernel FPU emulation. Note that many common MIPS-based routers lack an FPU and have firmware that doesn't enable kernel FPU emulation; Go won't run on such machines.


Владельцы arm роутеров с CPU без поддержки операций с плавающей точкой дожны устанавливать теперь go пакеты с суффиксом _nohf. Например `opkg install syncthing_nohf` или 'opkg install rclone_nohf`. На НАСах с armv7 как правило есть поддержка hard float.

Используется новый тулчейн - binutils 2.27, gcc 6.3, glibc 2.25. В связи с изменением soname у libc обновлены инсталляторы. Заново устанавливать Entware-3x не нужно. Просто штатно обновитесь.

Voxel
Сообщения: 35
Зарегистрирован: 29 фев 2016, 12:34

Сообщение Voxel » 22 фев 2017, 15:31

Спасибо! Все собирается.

Voxel.


Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 0 посетителей :: 0 зарегистрированных, 0 скрытых и 0 гостей (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей