Entware-3x - новые репозитории Entware для устройств, использующих новые ядра.

Используем пакеты, расширяющие возможности оборудования
pashinsky
Сообщения: 28
Зарегистрирован: 18 окт 2015, 14:02

Сообщение pashinsky » 23 ноя 2016, 10:58

<удалено администрацией - избыточное цитирование>
Как добавить пользователя в группу sudo?
почитал Entware - пример настройки и использования Openssh сервера http://forums.zyxmon.org/viewtopic.php?f=5&t=5261 но чет не разобрался
MQ-WITI_256 3.4.3.9-099_5aa2a75, Entware-3x, DebianChroot

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1147
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 23 ноя 2016, 11:28

pashinsky, это тема по установке Entware-3x. Установили? Остальные вопросы в (отдельных) других темах.
PS Пример с adduser есть на первой странице.

Sasha
Сообщения: 8
Зарегистрирован: 20 окт 2016, 22:06

Сообщение Sasha » 25 ноя 2016, 21:40

Установил Entware-3x для mips на Keenetic DSL прошивка 2.08.
После установки возникли проблемы с локализацией, вот так выглядит mc:
 
mc.jpg
Свернуть

Команда locale.new -a выдает:

Код: Выделить всё

~ # locale.new -a
locale.new: Cannot set LC_CTYPE to default locale: No such file or directory
locale.new: Cannot set LC_MESSAGES to default locale: No such file or directory
locale.new: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX

При добавлении локали выдает:

Код: Выделить всё

~ # localedef.new  -c -f UTF-8 -i ru_RU ru_RU.UTF-8
Segmentation fault

Как это можно поправить?
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1147
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 25 ноя 2016, 22:42

Sasha писал(а):Источник цитаты Как это можно поправить?

Причина (теоретически) понятна. При установке не хватило памяти для создания бинарного файла с локалями. В этом случае скачивается готовый файл с локалями. Так вот этот готовый файл создан для mipsel, a не mips.

Давайте проверим теорию.
1) Добавим swap через морду (с запасом - 512МБ)
2) Удалим файл с локалями

Код: Выделить всё

rm -f /opt/usr/lib/locale/locale-archive

3) Создадим новый

Код: Выделить всё

/opt/bin/localedef.new -c -f UTF-8 -i ru_RU ru_RU.UTF-8


PS На этапе (3) можно просто запустить скрипт `/opt/lib/opkg/info/locales.postinst` и посмотреть, что происходит!

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1147
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 25 ноя 2016, 22:47

@TheBB Если теория верна, нужно выложить locale-archive и в скрипте (установки для mips be) изменить URL для скачивания этого бинарного файла.

Sasha
Сообщения: 8
Зарегистрирован: 20 окт 2016, 22:06

Сообщение Sasha » 25 ноя 2016, 23:06

Все получилось, благодарствую.

Sasha
Сообщения: 8
Зарегистрирован: 20 окт 2016, 22:06

Сообщение Sasha » 25 ноя 2016, 23:13

А меню в mc с локализацией ru_RU должно быть на каком языке?
У меня сейчас на английском.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1147
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 25 ноя 2016, 23:28

Sasha, дата (Modify time) на русском, остальное на английском.

Sasha
Сообщения: 8
Зарегистрирован: 20 окт 2016, 22:06

Сообщение Sasha » 25 ноя 2016, 23:46

Тогда все верно, вот результат:
 
mc2.jpg
Свернуть
У вас нет необходимых прав для просмотра вложений в этом сообщении.

Xaber
Сообщения: 3
Зарегистрирован: 22 дек 2016, 16:37

Сообщение Xaber » 22 дек 2016, 16:44

Установил на роутер по вашему описанию Entware-3x (прошивка Padavan).
Вроде получилось, но при каждом запуске OPKG вот такое:
opkg update
Package ext-ui-lighttpd version 0.1-4a has no valid architecture, ignoring.
Package ext-ui-lighttpd-7 version 0.1-1a has no valid architecture, ignoring.
Package ext-ui-nginx version 0.1-5a has no valid architecture, ignoring.
Package ext-ui-nginx-7 version 0.1-1a has no valid architecture, ignoring.
Package libndm version 1.1.0-1a has no valid architecture, ignoring.
Package music-center version 0.1-2c has no valid architecture, ignoring.
Package ndmq version 1.0.2-1a has no valid architecture, ignoring.
Package opt-ndmsv2 version 1.0-5c has no valid architecture, ignoring.
Downloading http://entware-3x.zyxmon.org/binaries/m ... ackages.gz.
Updated list of available packages in /opt/var/opkg-lists/packages.
Свернуть

Ну и смущает меня ldconfig
ldconfig -v
ldconfig: Path `/lib' given more than once
ldconfig: Can't stat /lib32: No such file or directory
ldconfig: Can't stat /lib64: No such file or directory
/lib:
libz.so.1 -> libz.so.1.2.8
libuuid.so.1 -> libuuid.so.1.3.0
libutil.so.0 -> libutil-0.9.33.2.so
libusb-1.0.so.0 -> libusb-1.0.so.0.1.0
libssl.so.1.0.0 -> libssl.so.1.0.0
libshared.so -> libshared.so
librt.so.0 -> librt-0.9.33.2.so
libresolv.so.0 -> libresolv-0.9.33.2.so
libpthread.so.0 -> libpthread-0.9.33.2.so
libnsl.so.0 -> libnsl-0.9.33.2.so
libm.so.0 -> libm-0.9.33.2.so
libiw.so.30 -> libiw.so.30
libiconv.so.2 -> libiconv.so.2.5.0
libext2fs.so.2 -> libext2fs.so.2.4
libe2p.so.2 -> libe2p.so.2.3
libdl.so.0 -> libdl-0.9.33.2.so
libdisk.so -> libdisk.so
libcrypto.so.1.0.0 -> libcrypto.so.1.0.0
libcrypt.so.0 -> libcrypt-0.9.33.2.so
libcom_err.so.2 -> libcom_err.so.2.1
libc.so.0 -> libuClibc-0.9.33.2.so
libblkid.so.1 -> libblkid.so.1.1.0
ld-uClibc.so.0 -> ld-uClibc-0.9.33.2.so
Свернуть

Я ожидал, что uClibc заменится на Glibc, а с библиотеками кажется ничего не изменилось... Или у меня криво встал Entware-3x?


Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 4 посетителя :: 2 зарегистрированных, 0 скрытых и 2 гостя (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: Google Adsense [Bot], Yandex [Bot] и 2 гостя