nginx+php+mysql на Entware(mipsel)

Используем пакеты, расширяющие возможности оборудования
Аватара пользователя
Zyxmon
Администратор
Сообщения: 1147
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 10 апр 2016, 13:02

Yrzorg писал(а):Источник цитаты не стартует сервер

А что пишет. если ручками запустить, без скрипта?

Аватара пользователя
TheBB
Сообщения: 58
Зарегистрирован: 31 авг 2015, 01:24
Откуда: 26 ~44.09,43.02

Сообщение TheBB » 10 апр 2016, 13:08

Yrzorg писал(а):Источник цитаты... в my.cnf ничего не менял...

а зря... вот

Код: Выделить всё

datadir = /opt/var/mysql
а, благодаря вам, нашлась очипятка
datadir = /opt/var/mysqld/
Keenetic Giga II NDMSv.2.06/2.09 + Entware-Keenetic/Entware-ng-3x&Gentoo; Keenetic DSL NDMSv.2.05/2.08 + Entware-Keenetic/Entware-ng-3x&Debian

Yrzorg
Сообщения: 58
Зарегистрирован: 05 окт 2015, 12:23

Сообщение Yrzorg » 10 апр 2016, 15:23

TheBB писал(а):Источник цитаты а, благодаря вам, нашлась очипятка
datadir = /opt/var/mysqld/

у меня так и стоит в my.cnf
Zyxmon писал(а):Источник цитаты А что пишет. если ручками запустить, без скрипта?

это типа вот так?

Код: Выделить всё

/opt/bin/mysqld
160410 15:18:33 [Warning] Can't create test file /opt/var/mysqld/Keenetic_Ultra.lower-test
160410 15:18:33 [Warning] Can't create test file /opt/var/mysqld/Keenetic_Ultra.lower-test
/opt/bin/mysqld: Can't change dir to '/opt/var/mysqld/' (Errcode: 2)
160410 15:18:33 [ERROR] Aborting
160410 15:18:33 [Note] /opt/bin/mysqld: Shutdown complete


UPD
всё, удалось запустить
оказалось всё просто - запутался в конфиге и папках /mysql/ и /mysqld/
Keenetic Ultra II+Entware
padavan 3.4.3.9-099

lichtenshtein
Сообщения: 16
Зарегистрирован: 15 апр 2016, 03:24

Сообщение lichtenshtein » 19 апр 2016, 19:44

TheBB, можно услышать от Вас совет по настройке torrentmonitor на связке lighttpd+php+mysql? Очень долго провозился с ним, но так ничего не заработало. Всё упирается в то, что когда я захожу в вебморду TM и ввожу стандартный пароль (torrentmonitor) - я всё время получаю белый экран. Не важно какую базу данных я использую (пробовал и c sqlite) или сервер (пробовал с nginx) - всегда всё одно и то же. Причём с логах то ничего нет и даже не знаю, откуда копать и на что думать. lighttpd ставился вместе с пакетом rtorrent-easy-install, дальше по инструкции самого TM и примерно как в вашем посте http://forums.zyxmon.org/viewtopic.php?p=14890#p14890. Firebug показывает, что в header.php не подгружаются скрипты, но даже если их "подгрузить", всё равно ничего не работает. Да и рядом вполне прекрасно крутится веб-морда rutorrent, так что дело в чём-то другом, вот только в чём - мне не понятно.
Truumann

Аватара пользователя
TheBB
Сообщения: 58
Зарегистрирован: 31 авг 2015, 01:24
Откуда: 26 ~44.09,43.02

Сообщение TheBB » 21 апр 2016, 00:59

lichtenshtein писал(а):Источник цитаты... вот только в чём - мне не понятно

не хватает/не установлены php5-mod-*
Keenetic Giga II NDMSv.2.06/2.09 + Entware-Keenetic/Entware-ng-3x&Gentoo; Keenetic DSL NDMSv.2.05/2.08 + Entware-Keenetic/Entware-ng-3x&Debian

lichtenshtein
Сообщения: 16
Зарегистрирован: 15 апр 2016, 03:24

Сообщение lichtenshtein » 21 апр 2016, 02:13

TheBB писал(а):Источник цитаты не хватает/не установлены php5-mod-*

Каких не хватает, подскажите пожалуйста.
opkg list-installed
bash - 4.3.42-1a
boost-date_time - 1_60_0-1
boost-filesystem - 1_60_0-1
boost-program_options - 1_60_0-1
boost-regex - 1_60_0-1
boost-system - 1_60_0-1
coreutils - 8.23-2
coreutils-id - 8.23-2
coreutils-stat - 8.23-2
curl - 7.48.0-1
findutils - 4.6.0-1
glib2 - 2.46.2-1
gzip - 1.6-1a
ldconfig - 1.0.13-3
libatomic - 5.3.0-3
libattr - 20150922-1
libblkid - 2.25.2-4
libbz2 - 1.0.6-2
libc - 1.0.13-3
libcurl - 7.48.0-1
libevent2 - 2.0.22-1
libffi - 3.0.13-1
libfreetype - 2.5.5-2
libgcc - 5.3.0-3
libiconv-full - 1.11.1-2
libintl-full - 0.19.6-2
libjpeg - 9a-1
libltdl - 2.4-1
liblua - 5.1.5-1
libmcrypt - 2.5.8-2
libmount - 2.25.2-4
libmysqlclient - 5.1.73-2
libncurses - 6.0-1
libncursesw - 6.0-1
libopenssl - 1.0.2g-1
libpcre - 8.38-1
libpng - 1.2.56-1
libpthread - 1.0.13-3
libreadline - 6.3-1
librt - 1.0.13-3
libsigcxx - 2.5.4-1
libslang2 - 2.3.0-1
libsqlite3 - 3081101-1
libssh2 - 1.6.0-1
libssp - 5.3.0-3
libstdcpp - 5.3.0-3
libtorrent - 0.13.6-git-1-14e793b75dac95c51ad64ff9cd2dc6772b68c625
libuuid - 2.25.2-4
libxml2 - 2.9.3-1
lighttpd - 1.4.38-1
lighttpd-mod-access - 1.4.38-1
lighttpd-mod-auth - 1.4.38-1
lighttpd-mod-cgi - 1.4.38-1
lighttpd-mod-fastcgi - 1.4.38-1
lighttpd-mod-redirect - 1.4.38-1
lighttpd-mod-rewrite - 1.4.38-1
lighttpd-mod-scgi - 1.4.38-1
lua - 5.1.5-1
mc - 4.8.16-1a
mysql-server - 5.1.73-2
nginx - 1.9.12-1
php5 - 5.6.18-1
php5-cgi - 5.6.18-1
php5-cli - 5.6.18-1
php5-fastcgi - 5.6.18-1
php5-fpm - 5.6.18-1
php5-mod-curl - 5.6.18-1
php5-mod-gd - 5.6.18-1
php5-mod-json - 5.6.18-1
php5-mod-mbstring - 5.6.18-1
php5-mod-mcrypt - 5.6.18-1
php5-mod-pdo - 5.6.18-1
php5-mod-pdo-mysql - 5.6.18-1
php5-mod-pdo-sqlite - 5.6.18-1
php5-mod-session - 5.6.18-1
php5-mod-sqlite3 - 5.6.18-1
privoxy - 3.0.24-1
rtorrent-easy-install - 0.2-2
rtorrent-rpc - 0.9.6-git-1-62cb5a4605c0664bc522e0e0da9c72f09cf643a9
rutorrent - 3.7-2
rutorrent-plugin-_getdir - 3.7-2
rutorrent-plugin-autotools - 3.7-2
rutorrent-plugin-check_port - 3.7-2
rutorrent-plugin-chunks - 3.7-2
rutorrent-plugin-cookies - 3.7-2
rutorrent-plugin-edit - 3.7-2
rutorrent-plugin-erasedata - 3.7-2
rutorrent-plugin-extsearch - 3.7-2
rutorrent-plugin-feeds - 3.7-2
rutorrent-plugin-filedrop - 3.7-2
rutorrent-plugin-httprpc - 3.7-2
rutorrent-plugin-loginmgr - 3.7-2
rutorrent-plugin-retrackers - 3.7-2
rutorrent-plugin-rpc - 3.7-2
rutorrent-plugin-rss - 3.7-2
rutorrent-plugin-rssurlrewrite - 3.7-2
rutorrent-plugin-rutracker_check - 3.7-2
rutorrent-plugin-scheduler - 3.7-2
rutorrent-plugin-show_peers_like_wtorrent - 3.7-2
rutorrent-plugin-source - 3.7-2
rutorrent-plugin-theme - 3.7-2
rutorrent-plugin-throttle - 3.7-2
rutorrent-plugin-tracklabels - 3.7-2
screen - 4.3.1-1
sed - 4.2.2-1
terminfo - 6.0-1
tor - 0.2.7.6-1
tor-geoip - 0.2.7.6-1
wget - 1.17.1-1
xmlrpc-c - 1.39.0-1
xmlrpc-c-common - 1.39.0-1
xmlrpc-c-internal - 1.39.0-1
xmlrpc-c-server - 1.39.0-1
xupnpd - 404-1a
zlib - 1.2.8-1
zoneinfo-core - 2016b-1
zoneinfo-europe - 2016b-1
Свернуть
Truumann

Аватара пользователя
TheBB
Сообщения: 58
Зарегистрирован: 31 авг 2015, 01:24
Откуда: 26 ~44.09,43.02

Сообщение TheBB » 21 апр 2016, 02:22

php5-mod-simplexml
Keenetic Giga II NDMSv.2.06/2.09 + Entware-Keenetic/Entware-ng-3x&Gentoo; Keenetic DSL NDMSv.2.05/2.08 + Entware-Keenetic/Entware-ng-3x&Debian

lichtenshtein
Сообщения: 16
Зарегистрирован: 15 апр 2016, 03:24

Сообщение lichtenshtein » 21 апр 2016, 03:09

TheBB писал(а):Источник цитаты php5-mod-simplexml

Работает. Благодарю. :hi:
Truumann

kvi7
Сообщения: 24
Зарегистрирован: 28 мар 2016, 12:56
Откуда: Москва

Сообщение kvi7 » 24 апр 2016, 12:17

TheBB, Остановился на втором этапе. После запроса 192.168.1.1:88/phpinfo.php браузер показывает No input file specified.
Потребовалось скопировать файл phpinfo.php в папку /opt/share/nginx/html. Это выводит страницу PHP-FCGI TEST.

Заметил, что:
для установки nginx требуется ввести opkg install nginx-zyx
для установки указанных пакетов нужно вводить opkg install php5 php5-cli php5-fpm php5-fastcgi

Видимо нужно внести изменения в инструкцию по установке.

Аватара пользователя
TheBB
Сообщения: 58
Зарегистрирован: 31 авг 2015, 01:24
Откуда: 26 ~44.09,43.02

Сообщение TheBB » 24 апр 2016, 14:45

пост писался еще до выхода Entware-Keenetic. инструкция общая, показать осн. этапы установки и настройки.
Keenetic Giga II NDMSv.2.06/2.09 + Entware-Keenetic/Entware-ng-3x&Gentoo; Keenetic DSL NDMSv.2.05/2.08 + Entware-Keenetic/Entware-ng-3x&Debian


Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 0 посетителей :: 0 зарегистрированных, 0 скрытых и 0 гостей (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей