xupnpd - eXtensible UPnP agent

Используем пакеты, расширяющие возможности оборудования
maloy
Сообщения: 18
Зарегистрирован: 06 мар 2016, 10:28

Сообщение maloy » 14 мар 2016, 16:05

sysmer, спасибо огромное, вечером протещу и сообщу результаты.
А можете поделиться скриптом автозапуска Вашего сервера для init.d
И еще есть вопрос, а почему Вы пишете свое дополнение как отдельную примочку, а не как плагин к xupnpd, ну что бы положить его в папку плагинов xupnpd и он работал оттуда и что бы если в плейлисте шла ссылка ссылка

Код: Выделить всё

plugin=vps_tv.lua
то лист, даже не переделанный на адрес 127.0.0.1:8000, вещался через Ваш плагин и адрес "127.0.0.1:8000"?

maloy
Сообщения: 18
Зарегистрирован: 06 мар 2016, 10:28

Сообщение maloy » 14 мар 2016, 18:55

sysmer, высыпало ошибку

Код: Выделить всё

~ # not find m3u
client disconnect
not find m3u
client disconnect
client disconnect
lua: vps_tv.lua:128: bad argument #1 to 'pairs' (table expected, got nil)
stack traceback:
        [C]: in function 'pairs'
        vps_tv.lua:128: in main chunk
        [C]: ?

maloy
Сообщения: 18
Зарегистрирован: 06 мар 2016, 10:28

Сообщение maloy » 14 мар 2016, 19:12

Дальнейший тест, примерно через минуту просмотра

Код: Выделить всё

client disconnect
на трех разных плейлистах
И что самое печальное, что вылеты эти только на двух телевизорах samsung, если смотреть UPnP-IPTV на компьютере через проигрыватель windows media или на android через BubbleUPnP то вылетов нет :?
И еще, закинул плейлист без vps_tv

Код: Выделить всё

http://31.148.218.195:9091/udp/239.239.76.46:1234
он жутко тормозит, но вылетов нету, будет сыпаться картинка, будет крутить колесо загрузки, но не вылетит, а плей листы которые пытаюсь крутить через vps_tv вылетают, так же было с эдемом, но я думал что он вылетает из за нестабильности потока, но видимо нет, вот незадача :(

sysmer
Сообщения: 31
Зарегистрирован: 24 авг 2015, 15:47

Сообщение sysmer » 15 мар 2016, 12:35

Простите меня, накосячил чуток, тестаните вот это, должно все работать.
У вас нет необходимых прав для просмотра вложений в этом сообщении.

maloy
Сообщения: 18
Зарегистрирован: 06 мар 2016, 10:28

Сообщение maloy » 15 мар 2016, 19:54

sysmer, прошу прощения, но такая ржака :lol:
Теперь на телике ничего не вылетает, но показывает... :D
Начинает воспроизведение, кусок примерно секунд 15, потом повторяет тот же кусок, но уже без звука и + к нему секунд 5-10 продолжения вещания со звуком, потом целиком второй кусок без звука и еще + 5-10 секунд со звуком, сколько так может продолжаться не знаю :)
только прошу Вас не обижайтесь, к Вашей разработке претензий нет, просто ситуация вышла забавная.
Поправьте, если это возможно :oops:
И ловил еще ошибку

Код: Выделить всё

lua: vps_tv.lua:60: bad argument #1 to 'find' (string expected, got nil)
stack traceback:
        [C]: in function 'find'
        vps_tv.lua:60: in main chunk
        [C]: ?

по моему когда переключаешься с одного канала не другой, но ручаться не могу

maloy
Сообщения: 18
Зарегистрирован: 06 мар 2016, 10:28

Сообщение maloy » 15 мар 2016, 20:35

Погонял еще vps_tv.lua, потом вещание как-то прорывает, идет нормально, и вместо этих приколов с повторением прошлых моментов без звука, замерзает на непродолжительное время картинка и потом вещание идет ровно, как будто буфер уже забился и из него уже ничего не повторяет, а идут просто затыки в вещании. В общем пользоваться можно. Но доработать чутка нужно.
sysmer, Еще раз прошу прощения за предыдущий пост :)

sysmer
Сообщения: 31
Зарегистрирован: 24 авг 2015, 15:47

Сообщение sysmer » 18 мар 2016, 10:59

Написал небольшой скриптик для создания плейлиста для xupnpd от edem.tv с логотипами и сортировкой.
Он парсит плейлист и страничку эдема, скачивает логотипы и конвертирует их в jpg. (png логотипы телевизор не видит)
Для пользования нужен lua,curl и imagemagik c png jpg tool, а так же в сконфигурировать сам скрипт (там комменты на русском, надеюсь все там понятно).
У вас нет необходимых прав для просмотра вложений в этом сообщении.

sng58
Сообщения: 1
Зарегистрирован: 25 мар 2016, 23:33

Сообщение sng58 » 25 мар 2016, 23:50

Здравствуйте, хочу поделиться с вами моей бедой. Купил недавно телик SONY BRAVIA KDL-40R553C и 2 недели голову ломаю, не могу заставить работать плейлист через xupnpd. Расклад такой: телик сервер видит, плейлист открывает, но при попытке запустить канал выдает "Указанный файл не найден". Игррался с настройками плейлиста mpeg,mpeg1,mpeg_ts,m2ts ,mp4 dlna_extras=none,mpeg_ps_pal, ни к какому результату не приводит, такая же ошибка. Пример видео потока: http://10.12.0.19:8001/torrent/http%3A% ... stream.mp4
LG-SMARTV хавает на УРА. Есть предположение что видео плеер не поддерживает протокол HTTP, поэтому не находит виде поток. Прошу помощи или совета. Можно ли поднять xupnpd на этом телике??? Заранее Спасибо!!!

drpuh
Сообщения: 4
Зарегистрирован: 27 мар 2016, 19:09

Сообщение drpuh » 30 мар 2016, 20:44

Не отрабатывает плагин youtube, создаются пустые листы. На ютубе поменяли что то ?

mihd
Сообщения: 43
Зарегистрирован: 28 окт 2015, 16:45

Сообщение mihd » 31 мар 2016, 05:04

drpuh писал(а):Источник цитаты Не отрабатывает плагин youtube, создаются пустые листы. На ютубе поменяли что то ?

Ничего не поменяли. Только что смотрел очередной новый ролик с канала, на который подписан. С декабря прошлого года точно ничего не менялось


Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 0 посетителей :: 0 зарегистрированных, 0 скрытых и 0 гостей (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей