Обсуждение Tomatousb Shibby

ALEXSAV

Сообщение ALEXSAV » 31 мар 2012, 15:25

ALEXSAV писал(а):наблюдаю проблемы с tomato-K26USB-1.28.RT-N-MIPSR2-088V-AIO-rus-VladMgn:
1 При выставленной ширине канала 40 МГц не сохраняется и не применяется выбранный канал
2 Роутер не работает с шириной канала 40МГц , проверял на inSSIDer (или он вообще не работает с такой шириой? )
3 WiFi 802.11n работает только на 65Мбит, никак не могу добиться чтоб работал хотя бы на 150МБит на ширине канала 20МГц


Сам спросил - сам ответил :)
1 Канал шириной 40 Мгц НЕ РАБОТАЕТ когда в расширенных настройках выставлено Страна / Регион = Russian Federation
2 Работает, см. п.п.1 , желательно выставить Евросоюз чтоб были доступны 13 каналов, 14 официально в россии запрещён :)...
3 Удалось подключиться на скорости 150 МБит с ноутбука acer 3820T, однако работает нестабильно, т.к. у меня в округе 10 точек доступа и свободного места шириной в 40 МГц не нашлось :)

SkyAndroid

Сообщение SkyAndroid » 31 мар 2012, 21:45

skanik писал(а):
SkyAndroid писал(а):Смотрю VLC плеером на компе или через медиаплеер Popcorn A200 на телеке. Плейлист вот: http://download.ukrtelecom.ua/iptv/pls/iptv.m3u
Каналов , что то маловато, могу переделать плей лист все заработает, напишите внутренний IP адрес роутера.


Внутренний адрес роутера: 192.168.2.1 . Заранее благодарен за помощь! :)

http://us.ua/699471/ Не забудьте включить udpxy в межсетевом экране, если не заработает пишите.

myaso

Сообщение myaso » 01 апр 2012, 04:56

Когда же сделают прошивку, чтобы l2tp работал нормально. А то отваливается
Mar 30 20:19:25 88888 daemon.info xl2tpd[1271]: Can not find tunnel 4234 (refhim=0)
Mar 30 20:19:25 88888 daemon.debug xl2tpd[1271]: network_thread: unable to find call or tunnel to handle packet. call = 62375, tunnel = 4234 Dumping.

Может есть какой то способ поправить это в ручную, без прошивки?

Alas_Ka

Сообщение Alas_Ka » 01 апр 2012, 12:16

myaso
А у Вас обрывы идут постоянно и они мешают работе? Или просто в логах видете много таких записей, которые привели?
У меня тоже L2TP, но если соединение рвется, то оно успешно "подымается". В логе при этом в большом количестве примерно такие же записи как у Вас. Но где-то на просторах инета мне попалась информация, что это особенность xl2tpd - при обрыве связи xl2tpd предпринимает несколько попыток восстановить связь с предыдущим туннелем. Если ему (xl2tpd) не удается восстановить старый туннель, то он подключает новый. С тех пор я "не парюсь". Если обрывы и бывают (а еще надо понять по чьей вине - роутера или провайдера), то через минуту инет успешно восстанавливается.
А надежд на то, что будут править демон L2TP, по-моему немного.
Последний раз редактировалось Alas_Ka 01 апр 2012, 12:30, всего редактировалось 1 раз.

opendream

Сообщение opendream » 01 апр 2012, 12:24

Не хочет выполняться: e2fsck -f -y -v /dev/sda3
Пишет: e2fsck 1.38 (30-Jun-2005)
Backing up journal inode block information.
Pass 1: Checking inodes, blocks, and sizes
Error allocating block bitmap (1): Communication error on send
e2fsck:
Диск 1TB размонтирован:
ST310003 33AS
Раздел 'sda1' swap (249.00 МБ) не подключен
Раздел 'optware' ext3 (980.53 МБ) не подключен
Раздел 'data1' ext3 (930.31 ГБ) не подключен
Решил проверить, т.к. ни mc, ни tsansmission не видят свободное место на диске

myaso

Сообщение myaso » 01 апр 2012, 15:29

Alas_Ka писал(а):myaso
А у Вас обрывы идут постоянно и они мешают работе? Или просто в логах видете много таких записей, которые привели?
У меня тоже L2TP, но если соединение рвется, то оно успешно "подымается". В логе при этом в большом количестве примерно такие же записи как у Вас. Но где-то на просторах инета мне попалась информация, что это особенность xl2tpd - при обрыве связи xl2tpd предпринимает несколько попыток восстановить связь с предыдущим туннелем. Если ему (xl2tpd) не удается восстановить старый туннель, то он подключает новый. С тех пор я "не парюсь". Если обрывы и бывают (а еще надо понять по чьей вине - роутера или провайдера), то через минуту инет успешно восстанавливается.
А надежд на то, что будут править демон L2TP, по-моему немного.

Прошивка у меня tomato-K26USB-1.28.RT5x-MIPSR2-085V-AIO-Ru-Astra-v2
у меня если соединение оборвалось, то только такие записи и сыпятся. Может если пол часа подождать, связь подымется.
У меня на dlink-dir300 работал отлично интернет. На rt-n16 стандартной прошивки тоже нормально, но бывало то что раз в день(за долгий простой) рвется с этой ошибкой.
А тут в томато при изменении любой настройки, после сохранения связь рвется.
Чтобы не было такого, делаю так: жму в админке отключить интернет, отключаю кабель от интернета, правлю в настройках то что нужно, сохраняю. Потом выключаю из питания роутер, подключаю кабель интернета, подключаю питание роутера. И потом только соединяется. Ну согласитесь, это же не выход из ситуации... при каждом изменении любой настройки проделывать такое.

Vlad

Сообщение Vlad » 01 апр 2012, 15:43

opendream писал(а):Не хочет выполняться: e2fsck -f -y -v /dev/sda3
Пишет: e2fsck 1.38 (30-Jun-2005)
Backing up journal inode block information.
Pass 1: Checking inodes, blocks, and sizes
Error allocating block bitmap (1): Communication error on send
e2fsck:
Диск 1TB размонтирован:
ST310003 33AS
Раздел 'sda1' swap (249.00 МБ) не подключен
Раздел 'optware' ext3 (980.53 МБ) не подключен
Раздел 'data1' ext3 (930.31 ГБ) не подключен
Решил проверить, т.к. ни mc, ни tsansmission не видят свободное место на диске


На компе или виртуалке над подлечить..

Alas_Ka

Сообщение Alas_Ka » 01 апр 2012, 17:23

myaso писал(а):Прошивка у меня tomato-K26USB-1.28.RT5x-MIPSR2-085V-AIO-Ru-Astra-v2
у меня если соединение оборвалось, то только такие записи и сыпятся. Может если пол часа подождать, связь подымется...
А тут в томато при изменении любой настройки, после сохранения связь рвется...

По первой проблеме даже не знаю что сказать. У меня после 5-6 попыток "поднять" предыдущий туннель, vpn восстанавливается с новым туннелем.
То, что при изменении почти любой настройки рвется туннель L2TP подтверждаю. Но это скорее всего надо рассматривать как плату за то, что после изменения настроек не требуется производить полный рестарт роутера. Например на wl500gP с прошивкой Олега, после изменения какого-либо параметра, требовался полный рестарт роутера.
Конечно можете попробывать прошивку от Toastman, но по-моему xl2tpd в его прошивках "собран" точно также как у Shibby. Возможно есть особенность в работе L2TP именно с Вашим провайдером (к примеру с Билайном были проблемы в прошлом году, роутеры перестали подключаться к Билайну после изменения настроек на сети Билайна). Поищите на форуме Вашего провайдера - не жалуются ли линуксоиды именно на работу демона xl2tpd.

myaso

Сообщение myaso » 01 апр 2012, 17:41

Alas_Ka писал(а):По первой проблеме даже не знаю что сказать. У меня после 5-6 попыток "поднять" предыдущий туннель, vpn восстанавливается с новым туннелем.
То, что при изменении почти любой настройки рвется туннель L2TP подтверждаю. Но это скорее всего надо рассматривать как плату за то, что после изменения настроек не требуется производить полный рестарт роутера. Например на wl500gP с прошивкой Олега, после изменения какого-либо параметра, требовался полный рестарт роутера.
Поищите на форуме Вашего провайдера - не жалуются ли линуксоиды именно на работу демона xl2tpd.

А это и есть как бы одна проблема :) Просто так соединение на томате пока не разрывалось. Только при смене какой либо настройки. Ну можно же как то в следующую прошивку дополнить чтобы выполнялись следующие шаги при изменении настроек:
- отключение от интернета
- изменение настройки и сохранение
- перезагрузка роутера(или что нибудь придумать)
- подключение к интернету

на форуме моего провайдера тоже !ASUSники! жалуются на эту проблемму, но у них просто так, сам отваливается интернет иногда(с аналогичной ошибкой).

А у вас после изменения настроек l2tp поднимается сам через 5-6 попыток?

Alas_Ka

Сообщение Alas_Ka » 01 апр 2012, 18:00

myaso писал(а):...А у вас после изменения настроек l2tp поднимается сам через 5-6 попыток?

Да, соединение восстанавливается. Еще нашел такой способ, чтобы в логах было "почище". Переключится в режим DHCP, внести изменения. После того как роутер переподключится к провайдеру в режиме DHCP, переключаю режим в L2TP. Но в последнее время ленюсь, вношу изменения параметров, а на то что в логе много лишнего не обращаю внимания, соединение с интернетом ведь восстанавливается.
То что у других пользователей с роутером ASUS есть проблемы с L2TP может не иметь ничего общего с Вашими проблемами. Нужно обязательно учитывать на какой прошивке проблемы. В tomatousb для L2TP используется демон - xl2tpd, на прошивках энтузиастов другой демон (по-моему openl2tpd, но могу и ошибаться). Так что искать лучше именно, что пишут пользователи линукс (не обязательно на роутерах) о работе xl2tpd.


Вернуться в «TomatoUSB»

Кто сейчас на конференции

Всего 0 посетителей :: 0 зарегистрированных, 0 скрытых и 0 гостей (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей