Обсуждение TomatoUSB DualWan

don100

Сообщение don100 » 17 дек 2011, 11:16

Добрый день
у меня почему то в логе появляется такие записи
Dec 17 10:53:01 RT-N16 daemon.err miniupnpd[3343]: bind(natpmp): Address already in use
Dec 17 10:53:01 RT-N16 daemon.err miniupnpd[3343]: Failed to open sockets for NAT PMP.
и в итоге если отключить 1 канал (pppoe) то 2 канал (DHCP) можно сказать не работает, или сильно тормозит или вообще ничего не грузит.
Проверка соединений включена. Балансировка тоже. Локальные подсети раскидал по провайдерам в балансировке ( слава богу они не пересекаются).
Хотел узнать может кто связывался с такой ошибкой и что в данном случает можно сделать.

Shaman

Сообщение Shaman » 18 дек 2011, 08:07

don100 писал(а):Добрый день
у меня почему то в логе появляется такие записи
Dec 17 10:53:01 RT-N16 daemon.err miniupnpd[3343]: bind(natpmp): Address already in use
Dec 17 10:53:01 RT-N16 daemon.err miniupnpd[3343]: Failed to open sockets for NAT PMP.
и в итоге если отключить 1 канал (pppoe) то 2 канал (DHCP) можно сказать не работает, или сильно тормозит или вообще ничего не грузит.
Проверка соединений включена. Балансировка тоже. Локальные подсети раскидал по провайдерам в балансировке ( слава богу они не пересекаются).
Хотел узнать может кто связывался с такой ошибкой и что в данном случает можно сделать.

на оконечных устройствах нигде статика не прописана ?

don100

Сообщение don100 » 18 дек 2011, 09:27

Shaman писал(а):
don100 писал(а):Добрый день
у меня почему то в логе появляется такие записи
Dec 17 10:53:01 RT-N16 daemon.err miniupnpd[3343]: bind(natpmp): Address already in use
Dec 17 10:53:01 RT-N16 daemon.err miniupnpd[3343]: Failed to open sockets for NAT PMP.
и в итоге если отключить 1 канал (pppoe) то 2 канал (DHCP) можно сказать не работает, или сильно тормозит или вообще ничего не грузит.
Проверка соединений включена. Балансировка тоже. Локальные подсети раскидал по провайдерам в балансировке ( слава богу они не пересекаются).
Хотел узнать может кто связывался с такой ошибкой и что в данном случает можно сделать.

на оконечных устройствах нигде статика не прописана ?


Да есть на одном компе. Убрал, но ошибка все равно появляется, достаточно любого из провайдеров отключить и подключить заново.

Shaman

Сообщение Shaman » 18 дек 2011, 17:48

более подробный лог можно ?

don100

Сообщение don100 » 18 дек 2011, 19:29

Лог такой с момента отключения первого провайдера и подключения заново, все таки переключение происходит на второго провайдера,
когда первый раз проверял у второго провайдера были проблемы. Но все равно хотелось бы знать из-за чего ошибка.

 
Dec 18 19:19:21 RT-N16 user.info init[1]: stop_wanlink, WAN1 Disconnecting...
Dec 18 19:19:21 RT-N16 daemon.notice pppoe[1557]: Disconnected.
Dec 18 19:19:21 RT-N16 daemon.notice pppoe[1557]: Connect time 580.0 minutes.
Dec 18 19:19:21 RT-N16 daemon.notice pppoe[1557]: Sent 1319454710 bytes, received 1370989527 bytes.
Dec 18 19:19:22 RT-N16 user.notice root: Stop PolicyRouting ...
Dec 18 19:19:22 RT-N16 user.notice root: WAN1 disconnectd!
Dec 18 19:19:22 RT-N16 daemon.info dnsmasq[1567]: reading /etc/resolv.dnsmasq
Dec 18 19:19:22 RT-N16 daemon.info dnsmasq[1567]: using nameserver 86.110.181.14#53
Dec 18 19:19:22 RT-N16 daemon.info dnsmasq[1567]: using nameserver 10.112.255.86#53
Dec 18 19:19:22 RT-N16 user.notice root: clear route cache...
Dec 18 19:19:22 RT-N16 user.notice root: Stop PolicyRouting success.
Dec 18 19:20:50 RT-N16 user.info init[1]: start_wanlink, WAN1 connecting...
Dec 18 19:20:50 RT-N16 daemon.info dnsmasq[1567]: reading /etc/resolv.dnsmasq
Dec 18 19:20:50 RT-N16 daemon.info dnsmasq[1567]: using nameserver 86.110.181.14#53
Dec 18 19:20:50 RT-N16 daemon.info dnsmasq[1567]: using nameserver 10.112.255.86#53
Dec 18 19:20:50 RT-N16 daemon.notice pppoe[12506]: Connected.
Dec 18 19:20:50 RT-N16 daemon.notice pppoe[12506]: IP Address: 94.77.177.146
Dec 18 19:20:50 RT-N16 daemon.notice pppoe[12506]: DNS Address: 80.80.111.254, 80.80.111.244
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[1567]: reading /etc/resolv.dnsmasq
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[1567]: using nameserver 86.110.181.14#53
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[1567]: using nameserver 10.112.255.86#53
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[1567]: using nameserver 80.80.111.244#53
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[1567]: using nameserver 80.80.111.254#53
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[1567]: exiting on receipt of SIGTERM
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[12515]: started, version 2.55 cachesize 512
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[12515]: compile time options: no-IPv6 GNU-getopt no-RTC no-DBus no-I18N DHCP no-scripts TFTP
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq-dhcp[12515]: DHCP, IP range 192.168.7.100 -- 192.168.7.149, lease time 1d
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[12515]: reading /etc/resolv.dnsmasq
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[12515]: using nameserver 86.110.181.14#53
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[12515]: using nameserver 10.112.255.86#53
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[12515]: using nameserver 80.80.111.244#53
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[12515]: using nameserver 80.80.111.254#53
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[12515]: read /etc/hosts - 2 addresses
Dec 18 19:20:52 RT-N16 daemon.info dnsmasq[12515]: read /etc/hosts.dnsmasq - 7 addresses
Dec 18 19:20:54 RT-N16 daemon.notice miniupnpd[1729]: received signal 15, good-bye
Dec 18 19:20:54 RT-N16 user.info syslog: SNet version started
Dec 18 19:20:54 RT-N16 daemon.err miniupnpd[12653]: bind(natpmp): Address already in use
Dec 18 19:20:54 RT-N16 daemon.err miniupnpd[12653]: Failed to open sockets for NAT PMP.
Dec 18 19:20:54 RT-N16 user.notice root: Start PolicyRouting ...
Dec 18 19:20:55 RT-N16 user.notice root: WAN1_IFACE:ppp0, WAN1_IP:94.77.177.146, WAN1_GATEWAY:94.77.177.146
Dec 18 19:20:55 RT-N16 user.notice root: WAN2_IFACE:vlan3, WAN2_IP:10.114.140.70, WAN2_GATEWAY:10.114.140.65
Dec 18 19:20:55 RT-N16 user.notice root: disable rp_filter
Dec 18 19:20:55 RT-N16 user.notice root: set WAN1 route(94.77.177.146) for DNS:80.80.111.254
Dec 18 19:20:55 RT-N16 user.notice root: set WAN1 route(94.77.177.146) for DNS:80.80.111.244
Dec 18 19:20:55 RT-N16 user.notice root: set WAN2 route(10.114.140.65) for DNS:10.112.255.86
Dec 18 19:20:55 RT-N16 user.notice root: set WAN2 route(10.114.140.65) for DNS:86.110.181.14
Dec 18 19:20:55 RT-N16 user.notice root: set QQ&MSN via WAN1...
Dec 18 19:20:55 RT-N16 user.notice root: set route table 100...
Dec 18 19:20:55 RT-N16 user.notice root: set route table 200...
Dec 18 19:20:55 RT-N16 user.notice root: set default router with load-balance
Dec 18 19:20:55 RT-N16 user.notice root: clear route cache...
Dec 18 19:20:55 RT-N16 user.notice root: Start PolicyRouting success.
Dec 18 19:20:55 RT-N16 user.info syslog: LinkCheck V1.0 Started, Interval 10 secound
Dec 18 19:20:55 RT-N16 user.info syslog: wan1, checkhost0, 0.0.0.0
Dec 18 19:20:55 RT-N16 user.info syslog: wan2, checkhost0, 10.114.140.65
Свернуть

Shaman

Сообщение Shaman » 18 дек 2011, 20:21

как вариант предлагаю сменить внутреннюю сеть например на 192.168.240.0/24

и посмотреть маршрутизацию когда wan1 поднимается

SVD

Обсуждение tomato dual wan

Сообщение SVD » 19 дек 2011, 14:30

D.T. писал(а):Проблема.
Asus wl-500gpV2 прошивка tomato-K26USB-1.28.0539-MIPSR1-8M-rus.trx
Пытаюсь подключить 3G E367 Мегафон.
Пишет ROUTER daemon.err pppd[558]: In file /tmp/ppp/peers/3g2: unrecognized option '/dev/ttyUSB0'
Менял порты с 0-го по 4-й, чистил память.
Не получается. Модем мигает сначала зеленым глазом, потом синим и все.
Соединения нет.
У когото была такая пробема. Подскажите как её решить?

Скайлинковский ADU-310A подключил без проблем!


Проблема в модеме. Ставь прошивку 535 с ней работает.

D.T.

Обсуждение tomato dual wan

Сообщение D.T. » 19 дек 2011, 14:36

Спасибо.
А где ее взять можно?

don100

Сообщение don100 » 19 дек 2011, 20:23

Попробывал
Таблица маршрутизации оба канала подключены
 
Destination______Gateway___Genmask______Flags_MSS__Window__irtt__Iface
80.80.111.105___0.0.0.0___255.255.255.255__UH____0_____0______0___ppp0
10.114.140.65___0.0.0.0___255.255.255.255__UH____0_____0______0___vlan3
10.114.140.64___0.0.0.0___255.255.255.248__U_____0_____0______0___vlan3
192.168.17.0____0.0.0.0___255.255.255.0____U_____0_____0______0___br0
127.0.0.0_______0.0.0.0___255.0.0.0________U_____0_____0______0___lo
0.0.0.0______94.77.177.146____0.0.0.0______UG____0_____0______0___ppp0
Свернуть

Отключаю первый
 
Destination______Gateway___Genmask______Flags_MSS__Window__irtt__Iface
10.114.140.65___0.0.0.0___255.255.255.255__UH____0_____0______0___vlan3
10.114.140.64___0.0.0.0___255.255.255.248__U_____0_____0______0___vlan3
192.168.17.0____0.0.0.0___255.255.255.0____U_____0_____0______0___br0
127.0.0.0_______0.0.0.0___255.0.0.0________U_____0_____0______0___lo
0.0.0.0_____10.114.140.65__0.0.0.0_________UG____0_____0______0___vlan3
Свернуть

Подключаю первый канал таблица маршрутизации приходит в исходное состояние.
 
Destination______Gateway___Genmask______Flags_MSS__Window__irtt__Iface
80.80.111.105___0.0.0.0___255.255.255.255__UH____0_____0______0___ppp0
10.114.140.65___0.0.0.0___255.255.255.255__UH____0_____0______0___vlan3
10.114.140.64___0.0.0.0___255.255.255.248__U_____0_____0______0___vlan3
192.168.17.0____0.0.0.0___255.255.255.0____U_____0_____0______0___br0
127.0.0.0_______0.0.0.0___255.0.0.0________U_____0_____0______0___lo
0.0.0.0______94.77.177.146____0.0.0.0______UG____0_____0______0___ppp0
Свернуть

А в логе опять
Dec 19 19:35:49 RT-N16 daemon.err miniupnpd[22585]: bind(natpmp): Address already in use
Dec 19 19:35:49 RT-N16 daemon.err miniupnpd[22585]: Failed to open sockets for NAT PMP.

Еще заметил одну интересную вещь сейчас инет работает нормально, т.е. переключение происходит, если что качать с торрентов скорость складывается, но раздача идет только с WAN1 (где pppoe), причем выбирает всю ширину канала (если кто то подсоединится с локального треккера второго провайдера, только тогда работают оба), только отключаю WAN1 начинает раздавать со второго канала.

D.T.

Обсуждение tomato dual wan

Сообщение D.T. » 19 дек 2011, 21:05

Огромное спасибо SVD!
Все заработало.
Теперь бы с маршрутизацией попробовать разобраться.
Но это уже другая тема.


Вернуться в «TomatoUSB»

Кто сейчас на конференции

Всего 1 посетитель :: 0 зарегистрированных, 0 скрытых и 1 гость (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость