Объединение Entware-ng и Entware-3x. Теперь это просто Entware!!!

Используем пакеты, расширяющие возможности оборудования
Аватара пользователя
Zyxmon
Администратор
Сообщения: 1693
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 10 апр 2019, 14:03

anch665, Вам сюда - https://forum.keenetic.net/topic/5639-w ... p-and-ftps
На Telegram канале расскажут подробнее - https://t.me/Entware

snark
Сообщения: 1
Зарегистрирован: 28 май 2019, 10:47

Сообщение snark » 28 май 2019, 10:59

Новую тему не стал создавать
Что случилось с armv7sf-k2.6, все пакеты "has no valid architecture, ignoring."

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1693
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 28 май 2019, 11:15

snark, ошибка вышла. Исправлю в ближайшие чвс-два.

UPD Все должно сейчас работать

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1693
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 30 май 2019, 13:16

Changelog майского обновления
https://entware.net/2019/05/27/Changelog.html

Voxel
Сообщения: 88
Зарегистрирован: 29 фев 2016, 12:34

Сообщение Voxel » 06 июн 2019, 18:28

Спасибо за обновление!

Можно пару замечаний/предложений на будущее? В основном это для stubby (DoT). Ну и его зависимостей. Использую stubby в своей прошивке, так что уже столкнулся.

Основное новшество в пакетах OpenWRT - это переход на OpenSSL 1.1.1, а основное преимущество OpenSSL 1.1.1 - это TLSv1.3 (покруче шифрование, ну и быстрее работает). Так вот, stubby позволяет использовать серверы Cloudflare с DoT и с TLSv1.3. Но, чтобы это работало с Cloudflare, надо добавить в конфиги для OpenSSL 1.1.1:

Код: Выделить всё

CONFIG_OPENSSL_WITH_CHACHA_POLY1305=y
CONFIG_OPENSSL_PREFER_CHACHA_OVER_GCM=y


иначе не срабатывает для Cloudflare. Помимо этого, ChaCha - перспективное направление, и быстрее AES, если нет поддержки AES в CPU. Ну а в ARMv7 и ниже этой поддержки нет, только в ARMv8...

Еще, в стандартный Makefile из OpenWRT для getdns и unbound (зависимости для stubby) есть раздражающий баг (опенвртшный). Там для копирования библиотек используется строка (на примере getdns из Entware):

Код: Выделить всё

	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/opt/lib/libgetdns.so.* $(1)/opt/lib/


В результате в пакете в /opt/lib сидят два дубликата

libgetdns.so.10.1.2
libgetdns.so.10

то есть это идентичные файлы, тогда, как libgetdns.so.10 должна быть символьным линком на libgetdns.so.10.1.2

Ну и то же самое для libunbound, а эта штука довольно большая. Съедается пространство, да и неправильно это.

Лучше заменить в Makefile на

Код: Выделить всё

	$(CP) $(PKG_INSTALL_DIR)/opt/lib/libgetdns.so.* $(1)/opt/lib/


и тогда в ipk пойдут символьные линки.

Voxel.

Аватара пользователя
Александр Рыжов
Сообщения: 397
Зарегистрирован: 12 авг 2015, 13:14
Откуда: Смоленск

Сообщение Александр Рыжов » 06 июн 2019, 19:39

Спа-си-бо!
Voxel писал(а):Источник цитаты Еще, в стандартный Makefile из OpenWRT для getdns и unbound (зависимости для stubby) есть раздражающий баг (опенвртшный)

Сделаю PR'ы для OpenWrt'шников.

Update: готово.

Voxel
Сообщения: 88
Зарегистрирован: 29 фев 2016, 12:34

Сообщение Voxel » 07 июн 2019, 09:00

Александр Рыжов писал(а):Источник цитаты Update: готово.


:good:

Voxel

Voxel
Сообщения: 88
Зарегистрирован: 29 фев 2016, 12:34

Сообщение Voxel » 07 июн 2019, 12:38

Александр Рыжов писал(а):Источник цитаты Сделаю PR'ы для OpenWrt'шников.


Еще немного занудства с замечаниями/предложениями:

Там (в OpenWRT) еще не совсем понятен хронический отказ использования внешней библиотеки liblz4 для OpenVPN. В патчах OpenVPN с самого начала (2.4.0) лежит:

210-build_always_use_internal_lz4.patch

ну и, соответственно , это означает, что раьотает аналог liblz4 (LZ4 r131),тогда как начиная с LZ4 v1.7.3 можно увидеть в логе:

https://github.com/lz4/lz4/releases?after=v1.7.4

Improved: Significant speed boost on ARMv6 and ARMv7


И для этого буста достаточно добавить в Makefile

TARGET_CFLAGS += DLZ4_FORCE_MEMORY_ACCESS=1 -DXXH_FORCE_MEMORY_ACCESS=1

Оно так вроде побыстрее будет. Только не советую пока переходить на 1.9.x для ARM. Для Intel - ускорение, для ARM - чуть деградация. А вот LZ4 1.8.3 - вполне приличен.

Voxel.

Voxel
Сообщения: 88
Зарегистрирован: 29 фев 2016, 12:34

Сообщение Voxel » 07 июн 2019, 12:39

Обновление Entware для архитектуры Cortex-A15:

http://cortex-a15.zyxmon.org/binaries/cortex-a15-3x/

Voxel.

Voxel
Сообщения: 88
Зарегистрирован: 29 фев 2016, 12:34

Сообщение Voxel » 07 июн 2019, 12:46

Voxel писал(а):Источник цитаты И для этого буста достаточно добавить в Makefile

TARGET_CFLAGS += DLZ4_FORCE_MEMORY_ACCESS=1 -DXXH_FORCE_MEMORY_ACCESS=1


Имеется в виду в Makefile для liblz4

Voxel.


Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 3 посетителя :: 1 зарегистрированный, 0 скрытых и 2 гостя (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: CommonCrawl [Bot] и 2 гостя