Сравниваем astra, udpxy, msd_lite

Используем пакеты, расширяющие возможности оборудования
Crong
Сообщения: 19
Зарегистрирован: 29 ноя 2016, 14:01

Сравниваем решения astra, udpxy, msd_lite

Сообщение Crong » 13 дек 2016, 10:28

Здравствуйте, если возможно, соберите, пожалуйста: Multi Stream daemon Lite (msd_lite)
Исходные коды
Насколько я знаю, пакета в OpenWRT нет.

N56U_B1 3.4.3.9-099_5aa2a75, Entware-3x

Аватара пользователя
Александр Рыжов
Сообщения: 298
Зарегистрирован: 12 авг 2015, 13:14
Откуда: Смоленск

Соберите, пожалуйста, пакет ...

Сообщение Александр Рыжов » 13 дек 2016, 10:51

Crong, пробовал год-два назад, не пошло: он сильно завязан на определённые вызовы ядра и это никак не конфигурируется.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1208
Зарегистрирован: 09 авг 2015, 14:33

Соберите, пожалуйста, пакет ...

Сообщение Zyxmon » 13 дек 2016, 16:41

Crong, пакет можно собрать для entware-3x. Если Вы поставите entware-3x на Ваше устройство (оно поддерживает Entware-3x) - сообщите архитектуру, соберу пакет для тестирования.

Crong
Сообщения: 19
Зарегистрирован: 29 ноя 2016, 14:01

Соберите, пожалуйста, пакет ...

Сообщение Crong » 13 дек 2016, 16:46

Zyxmon, если можете, соберите, попробую поиграться. Entware-3x (стандартная установка) уже установлен, роутер RT-N56U_B1, как я понимаю mipsel.
Последний раз редактировалось Crong 13 дек 2016, 16:59, всего редактировалось 1 раз.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1208
Зарегистрирован: 09 авг 2015, 14:33

Соберите, пожалуйста, пакет ...

Сообщение Zyxmon » 13 дек 2016, 16:59

Crong, пробуйте, отписывайтесь - http://entware-3x.zyxmon.org/binaries/m ... sel-3x.ipk
Если работает - с Вас инструкция, скрипт запуска.

Crong
Сообщения: 19
Зарегистрирован: 29 ноя 2016, 14:01

Соберите, пожалуйста, пакет ...

Сообщение Crong » 13 дек 2016, 17:23

Zyxmon, спасибо, работает.
Запустил, пощелкал каналы, все работает.

Код: Выделить всё

/opt/bin/msd_lite -d -c /opt/etc/msd_lite.conf

По поводу скрипта запуска, я еще не настолько опытен чтобы сходу набросать скрипт.
PS. В конфиге нужно поправить строку, перенеся лог наверное в /tmp

Код: Выделить всё

<file>/root/msd_lite/msd_lite.log</file>

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1208
Зарегистрирован: 09 авг 2015, 14:33

Соберите, пожалуйста, пакет ...

Сообщение Zyxmon » 13 дек 2016, 18:15

Crong, просьба еще раз проверить (ссылка старая, удалите и поставьте заново).
Исправил конфиг, заменил /tmp на /opt/tmp и добавил скрипт запуска.

У меня в логе есть такое

Код: Выделить всё

[2016-12-13 18:08:37] http_srv_acc_add, line 502: io_net_is_tcp_cc_avail() fail, this is not fatal. error 22: Invalid argument
[2016-12-13 18:08:37]: bind 0.0.0.0:7088, backlog = 2048, cc_name = htcp
[2016-12-13 18:08:37] http_srv_acc_add, line 502: io_net_is_tcp_cc_avail() fail, this is not fatal. error 22: Invalid argument
[2016-12-13 18:08:37]: bind [::]:7088, backlog = 2048, cc_name = htcp


Если несложно - как используете, зачем прога?

Crong
Сообщения: 19
Зарегистрирован: 29 ноя 2016, 14:01

Соберите, пожалуйста, пакет ...

Сообщение Crong » 13 дек 2016, 18:26

Переустановил, работает.
msd_lite меньше грузит ЦП, скорее "нюхает". К примеру на двух 1080i каналах, два процесса udpxy в сумме потребляют ~5-6% ЦП, msd_lite ~2-3%.
На сайте автора есть скрины со сравнением загрузки ЦП.

У меня только при первом запуске на свеже запущенной системе, в логе появляются сообщения, при последующих запусках тихо.

Код: Выделить всё

Dec 13 17:30:38 kernel: warning: process `msd_lite' used the deprecated sysctl system call with 1.1.
Dec 13 17:30:38 kernel: warning: process `msd_lite' used the deprecated sysctl system call with 1.2.
Dec 13 17:30:38 kernel: warning: process `msd_lite' used the deprecated sysctl system call with 1.7.
Dec 13 17:30:38 kernel: warning: process `msd_lite' used the deprecated sysctl system call with 1.8.

Аватара пользователя
Александр Рыжов
Сообщения: 298
Зарегистрирован: 12 авг 2015, 13:14
Откуда: Смоленск

Соберите, пожалуйста, пакет ...

Сообщение Александр Рыжов » 13 дек 2016, 20:47

Ещё была некая Cesbro Astra с поддержкой LUA-скриптов, которая по словам проверявших тоже потребляла меньше udpxy. Насколько понял, за версию 2016 года теперь хотят денег.

Аватара пользователя
LordMerlin
Сообщения: 91
Зарегистрирован: 22 авг 2015, 14:31
Откуда: Третья планета от Солнца

Соберите, пожалуйста, пакет ...

Сообщение LordMerlin » 14 дек 2016, 10:59



Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 1 посетитель :: 1 зарегистрированный, 0 скрытых и 0 гостей (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: CommonCrawl [Bot] и 0 гостей