Entware-3x - новые репозитории Entware для устройств, использующих новые ядра.

Используем пакеты, расширяющие возможности оборудования
Аватара пользователя
Zyxmon
Администратор
Сообщения: 1147
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 19 окт 2016, 19:40

Voxel писал(а):Источник цитаты так как в самом пакете iptables нет зависимости от libnetfilter-conntrack.

Если это так, то вариантов два:
1) Добавить зависимость.
2) Добавить в Makefile псевдо зависимость PKG_BUILD_DEPENDS=.... для того, чтобы пакеты собирались в нужной последовательности.

PS В Дальнейшем подобные посты пишите в разделе - Собираем софт сами (пакеты, прошивки)

Voxel
Сообщения: 31
Зарегистрирован: 29 фев 2016, 12:34

Сообщение Voxel » 20 окт 2016, 10:31

Пардон, что не том разделе. Все же чуть продолжу, раз начал здесь.

Вариант 1 не пойдет, зачем делать новые зависимости, если работает и без них. За подсказку второго - спасибо.

Предложение для Вашей версии: обновить пакеты
OpenVPN 2.3.11->2.3.12
Ethtool 4.5->4.8

И все же, может, имеет смысл разрешить ассемблерную акселерацию в openssl для ARM? Достаточно убрать комментарии ('#') в Makefile:

Код: Выделить всё

else
  OPENSSL_OPTIONS+=no-sse2
  ifeq ($(CONFIG_mips)$(CONFIG_mipsel),y)
    OPENSSL_TARGET:=linux-mips-openwrt
#  else ifeq ($(CONFIG_arm)$(CONFIG_armeb),y)
#    OPENSSL_TARGET:=linux-armv4-openwrt
  else
    OPENSSL_TARGET:=linux-generic-openwrt
    OPENSSL_OPTIONS+=no-perlasm
  endif
endif


Все же и у Мерлина и в DD-WRT у Конга ассемблерная акселерация давно используется. Дает значительный прирост производительности OpenSSL.

Voxel.

Pasha_ZZZ
Сообщения: 35
Зарегистрирован: 31 окт 2015, 10:29

Сообщение Pasha_ZZZ » 28 окт 2016, 05:18

Поставил на ASUS N18U с крайней DD-WRT (DD-WRT v3.0-r30796 std (10/25/16)).
Скрипт для DD-WRT делает кучу всего не особо нужного, сейчас уже практически все есть в веб-морде.
Изображение
Создал на винте раздел 512 МБ, сменил тип на SWAP, потом mkswap /dev/sda1, второй раздел - все остальное.
UUID второго раздела - в Mount to /opt
Там же создал post-mount.sh

Код: Выделить всё

#!/bin/sh

/opt/etc/init.d/rc.unslung start
Перезагрузка, скрипт для armv7, перезагрузка.
Все заработало.

Pasha_ZZZ
Сообщения: 35
Зарегистрирован: 31 окт 2015, 10:29

Сообщение Pasha_ZZZ » 02 ноя 2016, 23:55

Zyxmon писал(а):Источник цитаты Очень желательно, чтобы версия ядра была бы не ниже 3.4.112 для mipsel устройств и 3.2.40 для остальных. Этим требованиям заведомо удовлетворяют прошивки Падавана
ASUS N65U, стояла самая последняя из Downloads проша от Падавана. uname -a говорит, что версия ядра 3.0.102.
Прошил самую распоследнюю, собранную роботами, от 18 октября - все равно ядро 3.0.102. А "очень желательно" 3.4.112.
Но опять же написано, что прошивки Падавана катят. Взаимоисключающие параграфы? Или они катят за счет бэкпортов?

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1147
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 03 ноя 2016, 00:37

Pasha_ZZZ писал(а):Источник цитаты ASUS N65U, стояла самая последняя из Downloads проша от Падавана. uname -a говорит, что версия ядра 3.0.102.

Для этой модели wi-fi драйвера в блобах (без исходников). поэтому и ядро не 3.4. ЕМНИП это единственное устройство с прошивкой Падавана и ядром 3.0.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1147
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 04 ноя 2016, 14:18

Проведена очередная синхронизация с openwrt.

Из наиболее важных изменений:

В openwrt удалили php5 и заменили его на php7. Мы пока оставили в репозитории оба варианта. Одновременно php5 и php7 устанавливать нельзя. рекомендуем перейти на php7.

inadyn - переход на версию 2 и изменение формата конфигурации (/opt/etc/inadyn.conf): https://github.com/troglobit/inadyn#exa ... figuration

seafile - обновление до версии 5.1.4

Как всегда обновлены версии пакетов, добавлены новые.
Общее число пакетов превыило 1950 (для x64 и armv7).

Pasha_ZZZ
Сообщения: 35
Зарегистрирован: 31 окт 2015, 10:29

Сообщение Pasha_ZZZ » 16 ноя 2016, 10:34

С недавних пор при каждом вызове OPKG первой строчкой

Код: Выделить всё

Package libite version 1.8.2-1a has no valid architecture, ignoring.
Entware-3x, ARMv7

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1147
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 16 ноя 2016, 11:20

Pasha_ZZZ писал(а):Источник цитаты С недавних пор при каждом вызове

Спасибо за сообщение. Исправили.

pashinsky
Сообщения: 28
Зарегистрирован: 18 окт 2015, 14:02

Сообщение pashinsky » 23 ноя 2016, 10:14

Как добавлять пользователей?

Код: Выделить всё

~ # useradd vasyapupkin
-sh: useradd: not found
MQ-WITI_256 3.4.3.9-099_5aa2a75, Entware-3x, DebianChroot

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1147
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 23 ноя 2016, 10:35

pashinsky писал(а):Источник цитаты Как добавлять пользователей?

Код: Выделить всё

~ # useradd vasyapupkin
-sh: useradd: not found

adduser


Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 2 посетителя :: 2 зарегистрированных, 0 скрытых и 0 гостей (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: CommonCrawl [Bot], Yandex [Bot] и 0 гостей