[Entware] lighttpd + php

Используем пакеты, расширяющие возможности оборудования
Аватара пользователя
TheBB
Сообщения: 77
Зарегистрирован: 31 авг 2015, 01:24
Откуда: 26 ~44.09,43.02

Сообщение TheBB » 20 дек 2016, 11:55

Прошу прощенья, ошибся при наборе :) . Пакет `php5-fastcgi`
Keenetic Giga II NDMSv.2.06/2.11 + Entware-Keenetic/Entware-ng-3x&Gentoo; Keenetic DSL NDMSv.2.05/2.11 + Entware-Keenetic/Entware-ng-3x&Debian

antonof
Сообщения: 12
Зарегистрирован: 02 дек 2016, 21:54

Сообщение antonof » 20 дек 2016, 14:47

TheBB писал(а):Источник цитаты Прошу прощенья, ошибся при наборе :) . Пакет `php5-fastcgi`

был установлен .

/opt/etc/lighttpd/conf.d # opkg install php5-fastcgi
Package php5-fastcgi (5.6.26-1) installed in root is up to date.

что в конфиге прописать?

fastcgi.server = ( ".php" =>
( "php-local" =>
(
"socket" => "/opt/tmp/php-fastcgi-1.socket",
"bin-path" => "/opt/bin/php-fcgi",
"max-procs" => 1,
"broken-scriptfilename" => "enable",
)
),

а в самом lighttpd.conf может еще что добавить надо?

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1333
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 20 дек 2016, 16:12

antonof писал(а):Источник цитаты что в конфиге прописать?


Вы как маленький ребенок, хотите, чтобы Вам все разжевали и в рот положили. Учитесь самостоятельно искать решение, экспериментировать, пробовать.
Вот руководство - http://maddog.sitengine.ru/smart-question-ru.html

antonof
Сообщения: 12
Зарегистрирован: 02 дек 2016, 21:54

Сообщение antonof » 20 дек 2016, 17:01

Zyxmon писал(а):Источник цитаты
antonof писал(а):Источник цитаты что в конфиге прописать?


Вы как маленький ребенок, хотите, чтобы Вам все разжевали и в рот положили. Учитесь самостоятельно искать решение, экспериментировать, пробовать.
Вот руководство - http://maddog.sitengine.ru/smart-question-ru.html

Уважаемый . Разве форум не для разжевывания?
Я все перепробовал , и после только написал . а не так нажал установить не пошло решил сразу написать.
И прошу помочь. Или данный форум только для программистов?

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1333
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 20 дек 2016, 17:18

antonof писал(а):Источник цитаты Разве форум не для разжевывания?

Однозначно нет. Вы не прочли важный документ, на который я дал ссылку.
Точно и детально опишите свою проблему
Внимательно и чётко опишите симптомы обнаруженной проблемы или ошибки
Опишите среду, в которой она возникает (компьютер, ОС, приложение и т.д.). Укажите дистрибутив и релиз (например: «Fedora Core 4», «Slackware 9.1» и т.п.).
Опишите проведённое вами исследование при попытках понять проблему прежде, чем задали свой вопрос.
Опишите какие вы предприняли самостоятельные шаги по диагностике и устранению проблемы прежде, чем задали свой вопрос.
Опишите последние изменения в конфигурации компьютера или программного обеспечения, которые могут иметь отношение к делу.

antonof писал(а):Источник цитаты Или данный форум только для программистов?

Нет, он для тех, кто думает. Так продемонстрируйте свои знания и опыт по решению возникшей проблемы, опишите, что делали, что не так. Подумайте почему это не так. Покажите, что прочли документацию к lighttpd.

antonof
Сообщения: 12
Зарегистрирован: 02 дек 2016, 21:54

Сообщение antonof » 20 дек 2016, 18:29

Я описал все в первом сообщение. Entware 3 , единственное не написал , может просто вернуть старую версию entware и все заработает.
Сделаю вывод на новой версии entware php в lighttpd Не работает.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1333
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 20 дек 2016, 19:49

antonof, на форумах есть такое нарушение - оверквотинг (избыточное цитирование). Ваш ответ существенно меньше цитируемого текста. Я пока отредактировал сообщение. В следующий раз удалю и за это дам недельный бан.

Вы ни слова не написали, как пытались решить проблему, что прочли из документации, смотрели ли логи lighttpd, запускали ли сервер руками без скрипта. Вы как маленький ребенок, которому нужно разжевать и положить в рот.
Будьте мужчиной! Шевелите извилинами. Прогаммистом быть не нужно, а вот думать - нужно!

antonof
Сообщения: 12
Зарегистрирован: 02 дек 2016, 21:54

Сообщение antonof » 20 дек 2016, 20:08

Zyxmon писал(а):Источник цитаты antonof, на форумах есть такое нарушение - оверквотинг (избыточное цитирование). Ваш ответ существенно меньше цитируемого текста. Я пока отредактировал сообщение. В следующий раз удалю и за это дам недельный бан.

Вы ни слова не написали, как пытались решить проблему, что прочли из документации, смотрели ли логи lighttpd, запускали ли сервер руками без скрипта. Вы как маленький ребенок, которому нужно разжевать и положить в рот.
Будьте мужчиной! Шевелите извилинами. Прогаммистом быть не нужно, а вот думать - нужно!

Я написал лог ошибки..

2016-12-18 18:44:26: (configfile.c.1078) source: cat /opt/etc/lighttpd/conf.d/*.conf line: 170 pos: 17 parser failed somehow near here: +=
2016-12-18 18:44:26: (configfile.c.1078) source: /opt/etc/lighttpd/lighttpd.conf line: 39 pos: 1 parser failed somehow near here: (EOL)

Вы ведете себя тут явно как будто у Вас корона. Мне порядочно лет, и моя профессия совсем не в данной области.
Если вы способны помочь , то помогите, проявите себя в данной области, вы же создали форум чтобы не другим указывать , что они не на что не способны.
но кроме правил в которые усердно тыкаете , Вы ничем не помогли.
Меня не нужно пугать недельным баном я не зависим от Вашего форма.

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1333
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 20 дек 2016, 21:14

antonof писал(а):Источник цитаты вы же создали форум чтобы не другим указывать , что они не на что не способны.

Я создал форум для тех, кто самостоятельно может решать проблемы, помогать другим, задавать нетривиальные вопросы. Из той информации, что Вы приводите, у Вас 2 ошибки в конфигах. Возможно одна наведена другой. (1) синтаксис, (2) непарные скобки. Искали? Гуглили? Конфиги отключали по одному?

antonof
Сообщения: 12
Зарегистрирован: 02 дек 2016, 21:54

Сообщение antonof » 21 дек 2016, 00:04

Решил вопрос самостоятельно.
так запустилось пхп

Код: Выделить всё

fastcgi.server += ( ".php" =>
        ((
                "bin-path" => "/opt/bin/php-cgi",
                "socket" => "/opt/tmp/php.socket",
                "max-procs" => 1,
                "bin-environment" => (
                        "PHP_FCGI_CHILDREN" => "4",
                        "PHP_FCGI_MAX_REQUESTS" => "10000"
                ),
                "bin-copy-environment" => (
                        "PATH", "SHELL", "USER"
                ),
                "broken-scriptfilename" => "enable"
        ))
)


Вернуться в «Entware/Qnapware/Optware/Zyxware - обсуждаем репозитории пакетов»

Кто сейчас на конференции

Всего 2 посетителя :: 2 зарегистрированных, 0 скрытых и 0 гостей (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: CommonCrawl [Bot], Yandex [Bot] и 0 гостей