Entware-Keenetic

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1803
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 09 дек 2019, 15:36

zyxeluser, изучайте это - https://github.com/ndmsystems/packages/ ... ok-scripts

zyxeluser
Сообщения: 46
Зарегистрирован: 29 авг 2017, 14:18

Сообщение zyxeluser » 09 дек 2019, 15:51

/opt/etc/ndm/netfilter.d/

Спасибо!

Я, в принципе, так и думал. Имя скрипта и права доступа значения имеют?

Аватара пользователя
Zyxmon
Администратор
Сообщения: 1803
Зарегистрирован: 09 авг 2015, 14:33

Сообщение Zyxmon » 09 дек 2019, 16:49

zyxeluser писал(а):Источник цитаты Имя скрипта и права доступа значения имеют?

Имя - не имеет значения. Исполняемым скрипт сделать нужно (скорее всего).

zyxeluser
Сообщения: 46
Зарегистрирован: 29 авг 2017, 14:18

Сообщение zyxeluser » 09 дек 2019, 21:30

Спасибо огромное! Сорри за оффтоп

mesb
Сообщения: 190
Зарегистрирован: 05 сен 2015, 23:47

Сообщение mesb » 26 янв 2020, 17:03

Господа, а что-то менялось в репе?

Использую чёрную Ultra первого поколения.
Давно ничего не обновлял, а тут думаю дай сделаю update и upgrade.

Апдейт прошёл нормально:
 
bash-5.0# opkg update
Downloading http://bin.entware.net/mipselsf-k3.4/Packages.gz
Updated list of available packages in /opt/var/opkg-lists/entware
Downloading http://bin.entware.net/mipselsf-k3.4/ke ... ackages.gz
Updated list of available packages in /opt/var/opkg-lists/keendev
Свернуть


А вот апгрейд начался, но пошёл не по плану:
 
bash-5.0# opkg upgrade
Upgrading terminfo on root from 6.1-4 to 6.1-5...
Downloading http://bin.entware.net/mipselsf-k3.4/te ... el-3.4.ipk
Upgrading opkg on root from 2019-01-31-d4ba162b-1 to 2019-06-14-dcbc142e-2...
Downloading http://bin.entware.net/mipselsf-k3.4/op ... el-3.4.ipk
Upgrading zoneinfo-europe on root from 2019a-1 to 2019c-1...
Downloading http://bin.entware.net/mipselsf-k3.4/zo ... el-3.4.ipk
Upgrading busybox on root from 1.30.1-2 to 1.31.0-1...
Downloading http://bin.entware.net/mipselsf-k3.4/bu ... el-3.4.ipk
Upgrading glib2 on root from 2.58.3-1 to 2.58.3-3...
Downloading http://bin.entware.net/mipselsf-k3.4/gl ... el-3.4.ipk
Upgrading bash on root from 5.0-2 to 5.0-3...
Downloading http://bin.entware.net/mipselsf-k3.4/ba ... el-3.4.ipk
Upgrading libcurl on root from 7.64.1-1 to 7.66.0-1...
Downloading http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk
Upgrading libssh2 on root from 1.8.2-1 to 1.9.0-2...
Downloading http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk
Upgrading mc on root from 4.8.22-1 to 4.8.23-2...
Downloading http://bin.entware.net/mipselsf-k3.4/mc ... el-3.4.ipk
Upgrading zoneinfo-asia on root from 2019a-1 to 2019c-1...
Downloading http://bin.entware.net/mipselsf-k3.4/zo ... el-3.4.ipk
Upgrading ndmq on root from 1.0.2-5 to 1.0.2-5a...
Downloading http://bin.entware.net/mipselsf-k3.4/ke ... 3.4_kn.ipk
Upgrading libblkid on root from 2.33-2 to 2.34-1...
Downloading http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk
Upgrading libmbedtls on root from 2.16.1-1 to 2.16.2-1...
Downloading http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk
Upgrading screen on root from 4.6.2-2 to 4.6.2-3...
Downloading http://bin.entware.net/mipselsf-k3.4/sc ... el-3.4.ipk
Upgrading liblua on root from 5.1.5-2 to 5.1.5-6...
Downloading http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk
Upgrading curl on root from 7.64.1-1 to 7.66.0-1...
Downloading http://bin.entware.net/mipselsf-k3.4/cu ... el-3.4.ipk
Upgrading libslang2 on root from 2.3.2-1 to 2.3.2-4...
Downloading http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk
Upgrading libuuid on root from 2.33-2 to 2.34-1...
Downloading http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk
Upgrading opt-ndmsv2 on root from 1.0-11 to 1.0-12...
Downloading http://bin.entware.net/mipselsf-k3.4/ke ... 3.4_kn.ipk
Upgrading libncurses on root from 6.1-4 to 6.1-5...
Downloading http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk
Upgrading libmount on root from 2.33-2 to 2.34-1...
Downloading http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk
Upgrading libncursesw on root from 6.1-4 to 6.1-5...
Downloading http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk
Upgrading findutils on root from 4.6.0-3 to 4.6.0-4...
Downloading http://bin.entware.net/mipselsf-k3.4/fi ... el-3.4.ipk
Upgrading libattr on root from 2.4.48-1 to 2.4.48-2...
Downloading http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk
Upgrading libopenssl on root from 1.1.1b-5 to 1.1.1d-1...
Downloading http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk
Upgrading libndm on root from 1.1.10-1 to 1.1.10-1a...
Downloading http://bin.entware.net/mipselsf-k3.4/ke ... 3.4_kn.ipk
Configuring terminfo.
Bad interpreter "/opt/bin/sh"
Configuring opkg.
Configuring zoneinfo-europe.
Configuring busybox.
Collected errors:
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/gl ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download glib2. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/ba ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download bash. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download libcurl. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download libssh2. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/mc ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download mc. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/zo ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download zoneinfo-asia. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/ke ... 3.4_kn.ipk, wget returned 255.
* opkg_install_pkg: Failed to download ndmq. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download libblkid. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download libmbedtls. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/sc ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download screen. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download liblua. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/cu ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download curl. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download libslang2. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download libuuid. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/ke ... 3.4_kn.ipk, wget returned 255.
* opkg_install_pkg: Failed to download opt-ndmsv2. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download libncurses. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download libmount. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download libncursesw. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/fi ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download findutils. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download libattr. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/li ... el-3.4.ipk, wget returned 255.
* opkg_install_pkg: Failed to download libopenssl. Perhaps you need to run 'opkg update'?
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/ke ... 3.4_kn.ipk, wget returned 255.
* opkg_install_pkg: Failed to download libndm. Perhaps you need to run 'opkg update'?
Свернуть


После чего апдейт уже всё, не срабатывал:
 
bash-5.0# opkg update
Downloading http://bin.entware.net/mipselsf-k3.4/Packages.gz
*** Failed to download the package list from http://bin.entware.net/mipselsf-k3.4/Packages.gz

Downloading http://bin.entware.net/mipselsf-k3.4/ke ... ackages.gz
*** Failed to download the package list from http://bin.entware.net/mipselsf-k3.4/ke ... ackages.gz

Collected errors:
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/Packages.gz, wget returned 255.
* opkg_download: Failed to download http://bin.entware.net/mipselsf-k3.4/ke ... ackages.gz, wget returned 255.
Свернуть


Систему реально починить без переустановки?

Аватара пользователя
Александр Рыжов
Сообщения: 420
Зарегистрирован: 12 авг 2015, 13:14
Откуда: Смоленск

Сообщение Александр Рыжов » 26 янв 2020, 17:11

wget развалился?

Код: Выделить всё

wget http://bin.entware.net/mipselsf-k3.4/Packages.gz

mesb
Сообщения: 190
Зарегистрирован: 05 сен 2015, 23:47

Сообщение mesb » 26 янв 2020, 17:16

Точно.
Однако попытка вкорячить его скачав курлом, приводит к меседжу похлеще:
 
bash-5.0# curl http://bin.entware.net/mipselsf-k3.4/wg ... el-3.4.ipk --output wget_1.20.3-2_mipsel-3.4.ipk
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 229k 100 229k 0 0 315k 0 --:--:-- --:--:-- --:--:-- 1629k

bash-5.0# opkg install wget_1.20.3-2_mipsel-3.4.ipk
Collected errors:
* pkg_init_from_file: Malformed package file wget_1.20.3-2_mipsel-3.4.ipk.
Свернуть

mesb
Сообщения: 190
Зарегистрирован: 05 сен 2015, 23:47

Сообщение mesb » 26 янв 2020, 18:11

Решил не мучиться пока а по быстрому сделал реинсталл.
Благо там немного ПО стояло.

Вообще помнится мне такой факап у меня изредка случаялся и на белой гиге.
Но там у меня упорно глюковали флешки от сандиска на 32 гига и я думал система бьётся.

brizx
Сообщения: 2
Зарегистрирован: 20 сен 2020, 15:16

Сообщение brizx » 20 сен 2020, 15:21

Кинетик экстра - не заходит по SSH связка логин root password keenetic
что делать?

brizx
Сообщения: 2
Зарегистрирован: 20 сен 2020, 15:16

Сообщение brizx » 20 сен 2020, 15:58

Здравствуйте.
Роутер кинетик экстра KN-1710
Делал все как написано здесь-
https://help.keenetic.com/hc/ru/articles/115005776589
Всё прошло как по маслу. Но при попытке зайти по SSH из Putty - логин root
пассворд -keenetic - пишет, что Доступ запрещен...Access denied
куда смотреть?
это вот тоже читал...-https://forum.keenetic.net/topic/4299-entware/


Вернуться в «Entware на Keenetic»

Кто сейчас на конференции

Всего 1 посетитель :: 1 зарегистрированный, 0 скрытых и 0 гостей (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (162) здесь было 16 ноя 2019, 17:33

Сейчас этот форум просматривают: CommonCrawl [Bot] и 0 гостей