Zyxel Keenetic не включается

Выбираем, обсуждаем, ремонтируем
JENEK11
Сообщения: 2
Зарегистрирован: 24 окт 2018, 11:10

Сообщение JENEK11 » 24 окт 2018, 14:42

Был прошит на вторую версию.Работал почки год без проблем, затем отказался включаться, вообще индикаторы не светятся, компьютер пытается поймать IP, но в итоге выдаёт 169 и на этом всё. Блок питания менял. Напряжение на AK17G на точках 1,2,3 - 0,26 1,52 3,28v, на катушках ( в питании) 1,6v и 5v. Процессор тёплый ( не перегревается). Пытался восстановить прошивку с оф. сайта - безуспешно. На передних трёх конденсаторах по 12.44 v. Может у кого есть схема, или точки промеров напряжение. Подскажите, кто что знает, заранее благодарен.

kaktus
Сообщения: 3
Зарегистрирован: 27 окт 2018, 11:05

Сообщение kaktus » 27 окт 2018, 22:47

Имеется Keenetic с аналогичными симптомами. Вышел из строя внезапно.
Напряжение в указанных точках совпадает.

Подключение к консоли с помощью USB UART, в моём случае, безрезультатно, что, на мой взгляд, свидетельствует о проблемах либо с загрузчиком (или чипом flash-памяти) либо с процессором (микротрещина в пайке из-за нагрева при штатном режиме работы).
Думаю начать с прогрева проца феном, но эта манипуляция довольно рискованная ввиду отсутствия опыта(

Кроме того, на плате имеется разъём JTAG с помощью которого, теоретически, можно проверить работу ЦП, памяти и, возможно, залить дамп.
Руководство по работе с JTAG, софт и рабочий дамп отсутствуют. Если у участников форума есть необходимое или опыт восстановления из подобного состояния, прошу откликнуться и поделиться.

Скорее всего ремонт будет не рентабельным, но коммерческой основы в деле нет, а железку пустить в утиль рука не поднимается)

JENEK11
Сообщения: 2
Зарегистрирован: 24 окт 2018, 11:10

Сообщение JENEK11 » 01 ноя 2018, 20:09

Проц прогрел, результат - 0, жду от китайцев USB к ttl конвертер UART, затем дальше колдовать буду.

lanuser
Сообщения: 2
Зарегистрирован: 17 ноя 2018, 13:12

Сообщение lanuser » 17 ноя 2018, 13:49

Мне то же нужна помощь гуру. Платка M01-BG419-E20. Очень похожий на WiKiDev: https://wikidevi.com/wiki/ZyXEL_NBG-419N_v1 только flash стоит MX29LV640EBTI-70G. Подключился на serial, результат: при включения питания - ничего, после замыкания контактов reset на самой плате, выдает:
U-Boot 1.1.3 (Aug 15 2011 - 19:14:56)

Board: Ralink APSoC DRAM: 32 MB
relocate_code Pointer at: 81fb0000

и дальше не грузится. На flash 3.28V присутствует. Диагноз? Можно его оживить. Работать вроде перестал после грозы. Напряжения промерил, кондеры не трогал, пока. Что посоветуете?

JENEC11: Я использую обычный переходник от старого телефона SonyEric. Определяется как Prolific. Эти переходники копейки стоят, т.к. не нужны уже никому. 5 минут делов паяльником.

kaktus
Сообщения: 3
Зарегистрирован: 27 окт 2018, 11:05

Сообщение kaktus » 18 ноя 2018, 23:01

lanuser писал(а):Источник цитаты после замыкания контактов reset на самой плате

А где эти контакты на плате... Параллельно кнопке Reset или я что-то просмотрел?

lanuser писал(а):Источник цитаты Что посоветуете?

Стоит попробовать залить дамп с рабочего, не забыв слить свой на всякий случай. Если в консоли что-то пишет, значит не всё так плохо)

lanuser
Сообщения: 2
Зарегистрирован: 17 ноя 2018, 13:12

Сообщение lanuser » 19 ноя 2018, 19:15

kaktus писал(а):А где эти контакты на плате... Параллельно кнопке Reset или я что-то просмотрел?

Просмотрел. Если открыть мою ссылку на wikidev постом ранее, вид "Board Top", подписаны как S2 HWRST.
kaktus писал(а):Стоит попробовать залить дамп с рабочего, не забыв слить свой на всякий случай.

Программатора под 29 серию у меня нет. Через JTAG попробую flash почитать, как и если смогу через JTAG до flash добраться. Судя по этой ветке с памятью порядок, а вот flash либо совсем, либо uboot поврежден.
kaktus писал(а):Напряжение в указанных точках совпадает.

А где посмотреть какие в каких точках?

kaktus
Сообщения: 3
Зарегистрирован: 27 окт 2018, 11:05

Сообщение kaktus » 23 ноя 2018, 17:35

lanuser писал(а):Источник цитаты А где посмотреть какие в каких точках?

Измерял в тех же точках что и ТС, т.к. другой инфы для сравнений нет.
Полезно было бы проверить питание на самой флешке (по datasheet), но думаю что дело не в этом.
На проц определённо что-то приходит, т.к. он слегка тёплый (в моём случае).
Также планирую заглянуть сперва на флешку... но как сделать это не выпаивая её инфы не нашел.

Замыкание S2 HWRST должного эффекта не возымело - в консоли по прежнему пусто.


Вернуться в «Маршрутизаторы, точки доступа, сетевые карты»

Кто сейчас на конференции

Всего 3 посетителя :: 1 зарегистрированный, 0 скрытых и 2 гостя (основано на активности пользователей за последние 5 минут)
Больше всего посетителей (121) здесь было 18 май 2016, 18:19

Сейчас этот форум просматривают: CommonCrawl [Bot] и 2 гостя